summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2017-06-14 13:48:11 -0700
committerMichael Hansen2017-06-14 13:48:11 -0700
commitd3d9c247b341e919462092b4e36e4e36c6fe19da (patch)
treebe202bb72cb5f09e5291c10446659d4c569c0a6e
parent45d4fa08da73a5f27a916d737146340b85725b83 (diff)
downloadaur-d3d9c247b341e919462092b4e36e4e36c6fe19da.tar.gz
Build fixes for gcc 7 and sphinx 1.6
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
-rw-r--r--lldb_missing_include.patch12
-rw-r--r--sphinx1.6.patch59
4 files changed, 90 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 961a0faf245c..39b96380f78c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed May 3 00:53:45 UTC 2017
+# Wed Jun 14 20:47:31 UTC 2017
pkgbase = swift-language
pkgdesc = The Swift programming language and debugger
pkgver = 3.1.1
- pkgrel = 2
+ pkgrel = 3
url = http://swift.org/
arch = i686
arch = x86_64
@@ -26,7 +26,6 @@ pkgbase = swift-language
depends = libxml2
depends = sqlite
depends = ncurses
- depends = libkqueue
depends = libblocksruntime
source = swift-3.1.1-RELEASE.tar.gz::https://github.com/apple/swift/archive/swift-3.1.1-RELEASE.tar.gz
source = swift-llvm-3.1.1-RELEASE.tar.gz::https://github.com/apple/swift-llvm/archive/swift-3.1.1-RELEASE.tar.gz
@@ -41,6 +40,8 @@ pkgbase = swift-language
source = swift-integration-tests-3.1.1-RELEASE.tar.gz::https://github.com/apple/swift-integration-tests/archive/swift-3.1.1-RELEASE.tar.gz
source = sourcekit_link_order.patch
source = icu59.patch
+ source = sphinx1.6.patch
+ source = lldb_missing_include.patch
sha256sums = 03eb54e7f89109a85c9b2a9bfdee88d2d7e1bdef73ae0385b30fe4661efaf407
sha256sums = fc6ac7c0c6afff344a8d4e5299b7417f414f1499cf374953e06c339d8177fc26
sha256sums = ed41f1231bae030a412455491a5244ede53a4761617194b2dda573f5776361ad
@@ -54,6 +55,8 @@ pkgbase = swift-language
sha256sums = fff8f596a7104ba5fc202dc5a80683032a33a298cf9ede7fdd12f7faf629a45c
sha256sums = c9aa6e167a57ed31002471204d39bf24bb4ebecc38322571515ac73f02b237b6
sha256sums = 3fedb626b375f6ad8b4601abd336f4560718a9c9134716f0c3a4e823b8c12857
+ sha256sums = 3c06dcc15bef6cbda7ce7b8a6a4f89bd16599ddbd1b964add9f2048cdda4700b
+ sha256sums = be61c69ae7bb626f7f07f95cb5c0074013725c1b90a3ca68aa0c0f989d75e41e
pkgname = swift
pkgdesc = The Swift programming language compiler and tools
diff --git a/PKGBUILD b/PKGBUILD
index bf5484970a1a..a8980e6c2f6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@ pkgbase=swift-language
pkgname=(swift swift-lldb)
_swiftver=3.1.1-RELEASE
pkgver=${_swiftver//-RELEASE/}
-pkgrel=2
+pkgrel=3
pkgdesc="The Swift programming language and debugger"
arch=('i686' 'x86_64')
url="http://swift.org/"
license=('apache')
depends=('python2' 'libutil-linux' 'icu' 'libbsd' 'libedit' 'libxml2'
- 'sqlite' 'ncurses' 'libkqueue' 'libblocksruntime')
+ 'sqlite' 'ncurses' 'libblocksruntime')
makedepends=('git' 'cmake' 'ninja' 'swig' 'clang>=3.8' 'python2-six' 'perl'
'python2-sphinx' 'python2-requests' 'rsync')
@@ -28,6 +28,8 @@ source=(
"swift-integration-tests-${_swiftver}.tar.gz::https://github.com/apple/swift-integration-tests/archive/swift-${_swiftver}.tar.gz"
"sourcekit_link_order.patch"
"icu59.patch"
+ "sphinx1.6.patch"
+ "lldb_missing_include.patch"
)
sha256sums=('03eb54e7f89109a85c9b2a9bfdee88d2d7e1bdef73ae0385b30fe4661efaf407'
'fc6ac7c0c6afff344a8d4e5299b7417f414f1499cf374953e06c339d8177fc26'
@@ -41,7 +43,9 @@ sha256sums=('03eb54e7f89109a85c9b2a9bfdee88d2d7e1bdef73ae0385b30fe4661efaf407'
'b711a5afaf027ac2cfefc144cd3760dd1d6a99689864be6ecb73a62cbb21b04f'
'fff8f596a7104ba5fc202dc5a80683032a33a298cf9ede7fdd12f7faf629a45c'
'c9aa6e167a57ed31002471204d39bf24bb4ebecc38322571515ac73f02b237b6'
- '3fedb626b375f6ad8b4601abd336f4560718a9c9134716f0c3a4e823b8c12857')
+ '3fedb626b375f6ad8b4601abd336f4560718a9c9134716f0c3a4e823b8c12857'
+ '3c06dcc15bef6cbda7ce7b8a6a4f89bd16599ddbd1b964add9f2048cdda4700b'
+ 'be61c69ae7bb626f7f07f95cb5c0074013725c1b90a3ca68aa0c0f989d75e41e')
prepare() {
# Use python2 where appropriate
@@ -74,6 +78,12 @@ prepare() {
# ICU 59 changed the type of UChar to char16_t
( cd "${srcdir}/swift" && patch -p1 -i "${srcdir}/icu59.patch" )
+
+ # Fix documentation build against Sphinx 1.6
+ ( cd "${srcdir}/swift" && patch -p1 -i "${srcdir}/sphinx1.6.patch" )
+
+ # LLDB is missing an include for std::bind with libstdc++/gcc7
+ ( cd "${srcdir}/lldb" && patch -p1 -i "${srcdir}/lldb_missing_include.patch" )
}
_common_build_params=(
diff --git a/lldb_missing_include.patch b/lldb_missing_include.patch
new file mode 100644
index 000000000000..ac192110668d
--- /dev/null
+++ b/lldb_missing_include.patch
@@ -0,0 +1,12 @@
+diff --git a/include/lldb/Utility/TaskPool.h b/include/lldb/Utility/TaskPool.h
+index db15b2081..3e6d5df8f 100644
+--- a/include/lldb/Utility/TaskPool.h
++++ b/include/lldb/Utility/TaskPool.h
+@@ -33,6 +33,7 @@
+ #include <queue>
+ #include <thread>
+ #include <vector>
++#include <functional>
+
+ // Global TaskPool class for running tasks in parallel on a set of worker thread
+ // created the first
diff --git a/sphinx1.6.patch b/sphinx1.6.patch
new file mode 100644
index 000000000000..9ccbea747be5
--- /dev/null
+++ b/sphinx1.6.patch
@@ -0,0 +1,59 @@
+diff -rupN a/docs/CMakeLists.txt b/docs/CMakeLists.txt
+--- a/docs/CMakeLists.txt 2017-04-21 14:18:29.000000000 -0700
++++ b/docs/CMakeLists.txt 2017-06-14 09:32:33.058127996 -0700
+@@ -11,7 +11,7 @@ SET(SWIFT_SPHINX_PAPER_SIZE "letter"
+
+ SET(SPHINX_ARGS
+ -W
+- -D latex_paper_size=${SWIFT_SPHINX_PAPER_SIZE}
++ -D latex_elements.papersize=${SWIFT_SPHINX_PAPER_SIZE}
+ -d ${CMAKE_BINARY_DIR}/doctrees)
+
+ if(SPHINX_EXECUTABLE)
+diff -rupN a/docs/conf.py b/docs/conf.py
+--- a/docs/conf.py 2017-04-21 14:18:29.000000000 -0700
++++ b/docs/conf.py 2017-06-14 10:03:22.266757932 -0700
+@@ -29,7 +29,7 @@ from datetime import date
+ extensions = ['sphinx.ext.intersphinx', 'sphinx.ext.todo']
+
+ # Add any paths that contain templates here, relative to this directory.
+-templates_path = ['_templates']
++templates_path = ['_templates', 'archive']
+
+ # The suffix of source filenames.
+ source_suffix = '.rst'
+@@ -146,7 +146,7 @@ html_last_updated_fmt = '%Y-%m-%d'
+
+ # Additional templates that should be rendered to pages, maps page names to
+ # template names.
+-html_additional_pages = {'LangRef': 'archive/LangRef.html'}
++html_additional_pages = {'archive/LangRef': 'LangRef.html'}
+
+ # If false, no module index is generated.
+ # html_domain_indices = True
+diff -rupN a/docs/Makefile b/docs/Makefile
+--- a/docs/Makefile 2017-04-21 14:18:29.000000000 -0700
++++ b/docs/Makefile 2017-06-14 09:28:39.455750766 -0700
+@@ -8,8 +8,8 @@ PAPER =
+ BUILDDIR = _build
+
+ # Internal variables.
+-PAPEROPT_a4 = -D latex_paper_size=a4
+-PAPEROPT_letter = -D latex_paper_size=letter
++PAPEROPT_a4 = -D latex_elements.papersize=a4
++PAPEROPT_letter = -D latex_elements.papersize=letter
+ ALLSPHINXOPTS = -W -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+ # the i18n builder cannot share the environment and doctrees with the others
+ I18NSPHINXOPTS = $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+diff -rupN a/docs/proposals/InitializerInheritance.rst b/docs/proposals/InitializerInheritance.rst
+--- a/docs/proposals/InitializerInheritance.rst 2017-04-21 14:18:29.000000000 -0700
++++ b/docs/proposals/InitializerInheritance.rst 2017-06-14 10:03:51.077044885 -0700
+@@ -135,7 +135,7 @@ doing so is safe.
+ Complete object initializers
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ Introduce the notion of a complete object initializer, which is
+-written as an initializer with ``Self`` as its return type [#], e.g.::
++written as an initializer with ``Self`` as its return type [#]_, e.g.::
+
+ init() -> Self {
+ // ...