summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2023-10-12 02:32:49 +0200
committersoloturn2023-10-12 02:32:49 +0200
commitf0573207fa3c7342298c0224b8b76536a27a8f4e (patch)
tree6bce04ed938f77c889e9b9d3d6607472133f03dc
parentfc3c9f8e5dbada50b777aae7a935313e4a266e77 (diff)
downloadaur-f0573207fa3c7342298c0224b8b76536a27a8f4e.tar.gz
rename also needs rename in other locations of script.
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index 33bae20c1542..0799bc2043c5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,10 +2,10 @@
/pkg/
*.tar.xz*
*.tar.gz*
-/cmark/
+/apple-cmark/
+/apple-llvm-project/
/indexstore-db/
/llbuild/
-/llvm-project/
/sourcekit-lsp/
/swift-argument-parser/
/swift-atomics/
diff --git a/PKGBUILD b/PKGBUILD
index cf938b5c1b2c..16f7549db464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -109,7 +109,7 @@ options=(!strip)
prepare () {
( cd swift && patch -p1 -i "$srcdir/0001-arch-aur-patches.patch" )
- ( cd llvm-project && patch -p1 -i "$srcdir/0002-stdint.patch" )
+ ( cd apple-llvm-project && patch -p1 -i "$srcdir/0002-stdint.patch" )
}
#pkgver() {
@@ -121,8 +121,8 @@ build() {
cd "$srcdir"
# Fix /usr/include error
find "$srcdir/swift/stdlib/public/SwiftShims" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
- find "$srcdir/llvm-project/clang" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
- find "$srcdir/llvm-project/clang-tools-extra" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
+ find "$srcdir/apple-llvm-project/clang" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
+ find "$srcdir/apple-llvm-project/clang-tools-extra" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
# By default in /etc/makepkg.conf this is "-D_FORTIFY_SOURCE=2"
# Which will break `compiler-rt`