summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2020-07-11 05:13:32 +0200
committersoloturn2020-07-11 05:13:32 +0200
commit2630573d79185a5445d492f188b00c930efb51f3 (patch)
treeb0b2a81b1c7a25530ddcbdcb5e63e16951d624c8
parent6d3213d1aec00aa552cfef393134ffaf49752688 (diff)
downloadaur-2630573d79185a5445d492f188b00c930efb51f3.tar.gz
python2 as fallback only, not required
-rw-r--r--.SRCINFO15
-rw-r--r--0003-swift-python2-as-fallback-only.patch25
-rw-r--r--PKGBUILD5
3 files changed, 39 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98d0966523ec..1c1e9562cdb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = swift-language-git
pkgdesc = The Swift programming language, taken directly from the Apple repository
- pkgver = swift.DEVELOPMENT.SNAPSHOT.2020.06.29.a.r38.g30ccb529485
+ pkgver = swift.DEVELOPMENT.SNAPSHOT.2020.07.09.a.r48.gb8b80b6b1cf
pkgrel = 1
url = https://swift.org/
arch = x86_64
license = apache2
+ makedepends = clang
+ makedepends = cmake
makedepends = git
makedepends = ninja
- makedepends = cmake
- makedepends = clang
+ makedepends = python-six
depends = icu
depends = libedit
depends = libxml2
@@ -18,7 +19,7 @@ pkgbase = swift-language-git
depends = ncurses
provides = swift-language
conflicts = swift-language-bin
- source = git+https://github.com/apple/swift#commit=30ccb5294
+ source = git+https://github.com/apple/swift
source = cmark::git+https://github.com/apple/swift-cmark
source = llbuild::git+https://github.com/apple/swift-llbuild
source = swift-argument-parser::git+https://github.com/apple/swift-argument-parser
@@ -31,7 +32,11 @@ pkgbase = swift-language-git
source = swift-corelibs-foundation::git+https://github.com/apple/swift-corelibs-foundation
source = swift-corelibs-libdispatch::git+https://github.com/apple/swift-corelibs-libdispatch
source = swift-integration-tests::git+https://github.com/apple/swift-integration-tests
- source = llvm-project::git+https://github.com/apple/llvm-project#commit=e80a6b097761253
+ source = llvm-project::git+https://github.com/apple/llvm-project#branch=apple/master
+ source = 0001-not-build-ninja-icu.patch
+ source = 0003-swift-python2-as-fallback-only.patch
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/0003-swift-python2-as-fallback-only.patch b/0003-swift-python2-as-fallback-only.patch
new file mode 100644
index 000000000000..f85ab214d40b
--- /dev/null
+++ b/0003-swift-python2-as-fallback-only.patch
@@ -0,0 +1,25 @@
+From a20416f07c26b8dbb62b0b0b2b51d47f658cc1b2 Mon Sep 17 00:00:00 2001
+From: soloturn <soloturn@gmail.com>
+Date: Sat, 11 Jul 2020 04:26:10 +0200
+Subject: [PATCH] swift python2 as fallback only
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c8f9999c2a..df2da5e731 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -889,7 +889,7 @@ if(NOT CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ endif()
+ endif()
+
+-find_package(Python2 COMPONENTS Interpreter REQUIRED)
++find_package(Python2 COMPONENTS Interpreter)
+ find_package(Python3 COMPONENTS Interpreter)
+ if(NOT Python3_Interpreter_FOUND)
+ message(WARNING "Python3 not found, using python2 as a fallback")
+--
+2.27.0
+
diff --git a/PKGBUILD b/PKGBUILD
index e7ffbb295013..939840a44ff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=swift-language-git
-pkgver=swift.DEVELOPMENT.SNAPSHOT.2020.07.02.a.r23.gb85ffd39f29
+pkgver=swift.DEVELOPMENT.SNAPSHOT.2020.07.09.a.r48.gb8b80b6b1cf
pkgrel=1
pkgdesc="The Swift programming language, taken directly from the Apple repository"
arch=('x86_64')
@@ -38,6 +38,7 @@ source=(
'llvm-project::git+https://github.com/apple/llvm-project#branch=apple/master'
# 'llvm-project::git+https://github.com/apple/llvm-project#commit=e80a6b097761253'
'0001-not-build-ninja-icu.patch'
+ '0003-swift-python2-as-fallback-only.patch'
)
noextract=()
md5sums=(
@@ -56,10 +57,12 @@ md5sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
prepare () {
( cd swift && patch -p1 -i "$srcdir/0001-not-build-ninja-icu.patch" )
+ ( cd swift && patch -p1 -i "$srcdir/0003-swift-python2-as-fallback-only.patch" )
}
pkgver() {