summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2020-08-01 14:16:51 +0200
committersoloturn2020-08-01 14:16:51 +0200
commita01d76a901e3c6ef42d2b9fd939bfd507b6bfc29 (patch)
tree775883df52478abd45422a73187969c6b7ff982d
parenta5d8c7744008050b7a2c80227b986d10b8b9cc31 (diff)
downloadaur-a01d76a901e3c6ef42d2b9fd939bfd507b6bfc29.tar.gz
adjust python2 patch to a couple of lines lower
-rw-r--r--.SRCINFO3
-rw-r--r--0003-swift-python2-as-fallback-only.patch4
-rw-r--r--PKGBUILD2
3 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c1e9562cdb2..ea93d49c7d30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = swift-language-git
pkgdesc = The Swift programming language, taken directly from the Apple repository
- pkgver = swift.DEVELOPMENT.SNAPSHOT.2020.07.09.a.r48.gb8b80b6b1cf
+ pkgver = swift.DEVELOPMENT.SNAPSHOT.2020.07.22.a.r354.g79ff5e36e8d
pkgrel = 1
url = https://swift.org/
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = swift-language-git
makedepends = git
makedepends = ninja
makedepends = python-six
+ makedepends = python2
depends = icu
depends = libedit
depends = libxml2
diff --git a/0003-swift-python2-as-fallback-only.patch b/0003-swift-python2-as-fallback-only.patch
index f85ab214d40b..399a00757ec7 100644
--- a/0003-swift-python2-as-fallback-only.patch
+++ b/0003-swift-python2-as-fallback-only.patch
@@ -11,13 +11,13 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8f9999c2a..df2da5e731 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -889,7 +889,7 @@ if(NOT CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+@@ -898,7 +898,7 @@ if(NOT CMAKE_SYSTEM_NAME STREQUAL "Darwin")
endif()
endif()
-find_package(Python2 COMPONENTS Interpreter REQUIRED)
+find_package(Python2 COMPONENTS Interpreter)
- find_package(Python3 COMPONENTS Interpreter)
+ find_package(Python3 COMPONENTS Interpreter REQUIRED)
if(NOT Python3_Interpreter_FOUND)
message(WARNING "Python3 not found, using python2 as a fallback")
--
diff --git a/PKGBUILD b/PKGBUILD
index 8a06eb23994a..52bd43cb1ff7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=swift-language-git
-pkgver=swift.DEVELOPMENT.SNAPSHOT.2020.07.09.a.r50.g00b3473fe36
+pkgver=swift.DEVELOPMENT.SNAPSHOT.2020.07.22.a.r354.g79ff5e36e8d
pkgrel=1
pkgdesc="The Swift programming language, taken directly from the Apple repository"
arch=('x86_64')