summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2021-07-19 09:37:05 +0200
committersoloturn2021-07-19 09:51:07 +0200
commita12b13700f599da359f40c033b1aba91bc43fa9f (patch)
tree846c419c3f56c5e3279d0d4c7bbfe8b5f7617a0b
parentd867fb5eb974162ff4c27f2794f7a5f13d65b1e8 (diff)
downloadaur-a12b13700f599da359f40c033b1aba91bc43fa9f.tar.gz
asprintf exists, patch it out, not ready for general linux like this
-rw-r--r--.SRCINFO4
-rw-r--r--0002-asprintf-exists.patch39
-rw-r--r--PKGBUILD6
3 files changed, 46 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de041752eb95..595acc21df46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = swift-language-git
pkgdesc = The Swift programming language, taken directly from the Apple repository
- pkgver = swift.DEVELOPMENT.SNAPSHOT.2021.06.01.a.r333.ga53ab388bbb
+ pkgver = swift.DEVELOPMENT.SNAPSHOT.2021.07.15.a.r122.g60a195e9721
pkgrel = 1
url = https://swift.org/
arch = x86_64
@@ -37,6 +37,7 @@ pkgbase = swift-language-git
source = swift-integration-tests::git+https://github.com/apple/swift-integration-tests#branch=main
source = llvm-project::git+https://github.com/apple/llvm-project#branch=swift/main
source = 0001-arch-aur-pachtes.patch
+ source = 0002-asprintf-exists.patch
source = indexstore-db::git+https://github.com/apple/indexstore-db#branch=main
source = yams::git+https://github.com/jpsim/Yams#commit=3.0.1
source = sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main
@@ -67,5 +68,6 @@ pkgbase = swift-language-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = swift-language-git
diff --git a/0002-asprintf-exists.patch b/0002-asprintf-exists.patch
new file mode 100644
index 000000000000..04a2b64338e1
--- /dev/null
+++ b/0002-asprintf-exists.patch
@@ -0,0 +1,39 @@
+From 51e6961d4a0d0fc5f92b686354c7e23d33e11048 Mon Sep 17 00:00:00 2001
+From: soloturn <soloturn@gmail.com>
+Date: Mon, 19 Jul 2021 09:29:44 +0200
+Subject: [PATCH] asprintf exists
+
+---
+ CoreFoundation/Base.subproj/CFPlatform.c | 2 +-
+ CoreFoundation/Base.subproj/CoreFoundation_Prefix.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CoreFoundation/Base.subproj/CFPlatform.c b/CoreFoundation/Base.subproj/CFPlatform.c
+index bf332973..ee5ae559 100644
+--- a/CoreFoundation/Base.subproj/CFPlatform.c
++++ b/CoreFoundation/Base.subproj/CFPlatform.c
+@@ -1472,7 +1472,7 @@ void _CF_dispatch_once(dispatch_once_t *predicate, void (^block)(void)) {
+ #pragma mark -
+ #pragma mark Windows and Linux Helpers
+
+-#if TARGET_OS_WIN32 || TARGET_OS_LINUX
++#if TARGET_OS_WIN32
+
+ #include <stdio.h>
+
+diff --git a/CoreFoundation/Base.subproj/CoreFoundation_Prefix.h b/CoreFoundation/Base.subproj/CoreFoundation_Prefix.h
+index 35e08036..86d6574a 100644
+--- a/CoreFoundation/Base.subproj/CoreFoundation_Prefix.h
++++ b/CoreFoundation/Base.subproj/CoreFoundation_Prefix.h
+@@ -414,7 +414,7 @@ CF_INLINE int popcountll(long long x) {
+ #define CF_TEST_PRIVATE CF_PRIVATE
+ #endif
+
+-#if TARGET_OS_LINUX || TARGET_OS_WIN32
++#if TARGET_OS_WIN32
+
+ #include <stdarg.h>
+
+--
+2.32.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 9e0b6bed9c5e..0858e7d4eaf9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,8 @@
# Contributor: Gábor Sebestyén <segabor@gmail.com>
# Contributor: Andrew Sun <adsun701@gmail.com>
-
pkgname=swift-language-git
-pkgver=swift.DEVELOPMENT.SNAPSHOT.2021.06.01.a.r333.ga53ab388bbb
+pkgver=swift.DEVELOPMENT.SNAPSHOT.2021.07.15.a.r122.g60a195e9721
pkgrel=1
pkgdesc="The Swift programming language, taken directly from the Apple repository"
arch=('x86_64')
@@ -32,6 +31,7 @@ source=(
'swift-integration-tests::git+https://github.com/apple/swift-integration-tests#branch=main'
'llvm-project::git+https://github.com/apple/llvm-project#branch=swift/main'
'0001-arch-aur-pachtes.patch'
+ '0002-asprintf-exists.patch'
'indexstore-db::git+https://github.com/apple/indexstore-db#branch=main'
'yams::git+https://github.com/jpsim/Yams#commit=3.0.1'
'sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main'
@@ -65,6 +65,7 @@ md5sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
@@ -77,6 +78,7 @@ options=(!strip)
prepare () {
( cd swift && patch -p1 -i "$srcdir/0001-arch-aur-pachtes.patch" )
+ ( cd swift-corelibs-foundation && patch -p1 -i "$srcdir/0002-asprintf-exists.patch" )
}
pkgver() {