summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2020-10-03 11:06:25 +0200
committersoloturn2020-10-03 11:22:17 +0200
commitd5df0d5d47ff2b00d72e9811319d1e45f0fd4f50 (patch)
tree40cc0d78000e8116c48c612084cc6fc4d2c3df5b
parent0aa1b1ff486f3f64aa8455da3ff81e44cba5927e (diff)
downloadaur-d5df0d5d47ff2b00d72e9811319d1e45f0fd4f50.tar.gz
2 integration tests are python2
-rw-r--r--0003-linux_load_commands-test-sourcekit-lsp-are-python2.patch32
-rw-r--r--PKGBUILD3
2 files changed, 35 insertions, 0 deletions
diff --git a/0003-linux_load_commands-test-sourcekit-lsp-are-python2.patch b/0003-linux_load_commands-test-sourcekit-lsp-are-python2.patch
new file mode 100644
index 000000000000..c878b0d15fc7
--- /dev/null
+++ b/0003-linux_load_commands-test-sourcekit-lsp-are-python2.patch
@@ -0,0 +1,32 @@
+From 37cfa25aa310f298c1649bbbabedcb6aae418e19 Mon Sep 17 00:00:00 2001
+From: soloturn <soloturn@gmail.com>
+Date: Sat, 3 Oct 2020 11:01:20 +0200
+Subject: [PATCH] linux_load_commands, test-sourcekit-lsp are python2
+
+---
+ test-snapshot-binaries/linux_load_commands.py | 1 +
+ test-sourcekit-lsp/test-sourcekit-lsp.py | 2 ++
+ 2 files changed, 3 insertions(+)
+
+diff --git a/test-snapshot-binaries/linux_load_commands.py b/test-snapshot-binaries/linux_load_commands.py
+index f7d044e..a021927 100644
+--- a/test-snapshot-binaries/linux_load_commands.py
++++ b/test-snapshot-binaries/linux_load_commands.py
+@@ -1,3 +1,4 @@
++#!/usr/bin/env python2
+
+ # REQUIRES: platform=Linux
+ # RUN: rm -rf %T && mkdir -p %t
+diff --git a/test-sourcekit-lsp/test-sourcekit-lsp.py b/test-sourcekit-lsp/test-sourcekit-lsp.py
+index b7e6323..02ede11 100644
+--- a/test-sourcekit-lsp/test-sourcekit-lsp.py
++++ b/test-sourcekit-lsp/test-sourcekit-lsp.py
+@@ -1,3 +1,5 @@
++#!/usr/bin/env python2
++
+ # Canary test for sourcekit-lsp, covering interaction with swiftpm and toolchain
+ # language services.
+
+--
+2.28.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 3b8e71af7a4a..5145528f421c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,6 +36,7 @@ source=(
'llvm-project::git+https://github.com/apple/llvm-project#branch=swift/master'
'0001-arch-aur-pachtes.patch'
'0002-llbuild-ninja-test-binary-links-against-ncurses.patch'
+ '0003-linux_load_commands-test-sourcekit-lsp-are-python2.patch'
# swift src to check afterwards
'indexstore-db::git+https://github.com/apple/indexstore-db'
# 'yams::git+https://github.com/jpsim/Yams'
@@ -71,6 +72,7 @@ md5sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
@@ -82,6 +84,7 @@ md5sums=(
prepare () {
( cd swift && patch -p1 -i "$srcdir/0001-arch-aur-pachtes.patch" )
( cd llbuild && patch -p1 -i "$srcdir/0002-llbuild-ninja-test-binary-links-against-ncurses.patch" )
+ ( cd swift-integration-tests && patch -p1 -i "$srcdir/0003-linux_load_commands-test-sourcekit-lsp-are-python2.patch" )
}
pkgver() {