summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2018-01-31 15:54:46 +0300
committerDaniel Bershatsky2018-01-31 15:54:46 +0300
commita7f39233b4d4613db3906e064b8b33f205b54bb9 (patch)
treea5b4aea7e80170a0e0c34ec05c0e522e8bba6f6f
downloadaur-a7f39233b4d4613db3906e064b8b33f205b54bb9.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD47
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df6ffa9c4bcf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = swift-protobuf-git
+ pkgdesc = CatBoost is an open-source gradient boosting on decision trees library with categorical features support out of the box.
+ pkgver = 1.0.2
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/apple/swift-protobuf
+ arch = i686
+ arch = x86_64
+ license = Apache-2.0
+ depends = protobuf
+ depends = swift-language
+ provides = swift-protobuf
+ source = swift-protobuf::git+https://github.com/apple/swift-protobuf.git
+ md5sums = SKIP
+
+pkgname = swift-protobuf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7088fbaa7884
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
+pkgname=swift-protobuf-git
+pkgver=1.0.2
+pkgrel=1
+epoch=0
+pkgdesc="Plugin and runtime library for using protobuf with Swift."
+arch=('i686' 'x86_64')
+url="https://github.com/apple/swift-protobuf"
+license=('Apache-2.0')
+depends=('protobuf' 'swift-language')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=('swift-protobuf')
+conflicts=()
+replaces=()
+backup=()
+options=()
+
+source=("swift-protobuf::git+https://github.com/apple/swift-protobuf.git")
+md5sums=('SKIP')
+
+validpgpkeys=()
+
+pkgver() {
+ cd "$srcdir/swift-protobuf"
+ version=$(git tag -l | tail -n 1)
+ digest=$(git describe --long --all)
+ release=$(sed "s/heads\/master/$version/" <<< $digest)
+ echo $release
+}
+
+package() {
+ cd $srcdir/swift-protobuf
+
+ version=$(git tag -l | tail -n 1)
+ git checkout tags/$version
+
+ swift build -c release -Xswiftc -static-stdlib
+}
+
+install() {
+ target=protoc-gen-swift
+ mkdir -p $pkgdir/usr/bin
+ cp $srcdir/swift-protobuf/.build/release/$target $pkgdir/usr/bin
+ chmod +x $pkgdir/usr/bin/$target
+}