summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkdols2023-09-19 21:04:05 -0500
committerMarkdols2023-09-19 21:04:05 -0500
commit564334e3fedb47904a5ddc487afc491ea5f472fc (patch)
tree40c37f6bf027f70b7bf9e8af23c6ad01286549c8
downloadaur-564334e3fedb47904a5ddc487afc491ea5f472fc.tar.gz
Initial AUR release of swiftly-bin 0.1.0
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa082ddfef7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = swiftly-bin
+ pkgdesc = A Swift toolchain installer and manager, written in Swift.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://swift-server.github.io/swiftly/
+ arch = x86_64
+ license = apache
+ depends = libutil-linux
+ depends = libxml2
+ depends = ncurses5-compat-libs
+ optdepends = python36: required for REPL
+ provides = swift-language
+ conflicts = swift-language
+ options = !strip
+ source = https://github.com/swift-server/swiftly/releases/download/0.1.0/swiftly-x86_64-unknown-linux-gnu
+ sha256sums = b3ef4e3d652a622af8f5ec54c1264e0ad9de37fa26e81cfe70649833c0039e45
+
+pkgname = swiftly-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..726229cd15c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mark <speedorama1 at gmail dot com>
+
+_pkgname=swiftly
+pkgname=swiftly-bin
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A Swift toolchain installer and manager, written in Swift."
+arch=('x86_64')
+url="https://swift-server.github.io/swiftly/"
+license=('apache')
+depends=('libutil-linux' 'libxml2' 'ncurses5-compat-libs')
+optdepends=('python36: required for REPL')
+options=('!strip')
+provides=(swift-language)
+conflicts=(swift-language)
+source=("https://github.com/swift-server/${_pkgname}/releases/download/${pkgver}/${_pkgname}-x86_64-unknown-linux-gnu")
+sha256sums=('b3ef4e3d652a622af8f5ec54c1264e0ad9de37fa26e81cfe70649833c0039e45')
+
+package() {
+ mkdir -p ~/.local/share/${_pkgname}/toolchains
+ echo "{ \"platform\": { \"name\": \"centos7\", \"nameFull\": \"centos7\", \"namePretty\": \"Arch Linux\" }, \"installedToolchains\": [] }" > ~/.local/share/${_pkgname}/config.json # basic config.json setup
+ install -D -m 0755 ${_pkgname}-x86_64-unknown-linux-gnu ${pkgdir}/usr/bin/${_pkgname}
+ echo "Config and toolchains can be found in ~/.local/share/swiftly. Toolchains are installed to ~/.local/bin."
+ echo "If you decide to uninstall, be sure to remove all toolchains first with \"swiftly uninstall (toolchain)\"."
+}