summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkdols2023-12-25 17:15:39 -0600
committerMarkdols2023-12-25 17:15:39 -0600
commit72c43b0b76b596db39b1ec245e97d565ab91c2ee (patch)
tree4aa8d3f8a1451827d57c6fb1ed8ab2c3985e5ef0
parentfcf935a9bf44b874c4d5840e05e9a3df814b8954 (diff)
downloadaur-72c43b0b76b596db39b1ec245e97d565ab91c2ee.tar.gz
bump to version 0.2.0, changed install script
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD10
-rw-r--r--swiftly-bin.install10
3 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1246df8412b0..e3a181011e56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = swiftly-bin
pkgdesc = A Swift toolchain installer and manager, written in Swift.
- pkgver = 0.1.0
- pkgrel = 2
+ pkgver = 0.2.0
+ pkgrel = 1
url = https://swift-server.github.io/swiftly/
install = swiftly-bin.install
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = swiftly-bin
provides = swift-language
conflicts = swift-language
options = !strip
- source = https://github.com/swift-server/swiftly/releases/download/0.1.0/swiftly-x86_64-unknown-linux-gnu
- sha256sums = b3ef4e3d652a622af8f5ec54c1264e0ad9de37fa26e81cfe70649833c0039e45
+ source = https://github.com/swift-server/swiftly/releases/download/0.2.0/swiftly-x86_64-unknown-linux-gnu
+ sha256sums = e0e58f6cbd4ad60c4cd51eeed88c3e908b3e2951bf55bcd3799fdd66d0fddbf4
pkgname = swiftly-bin
diff --git a/PKGBUILD b/PKGBUILD
index f13d73d49064..e6312e3c63ae 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=swiftly
pkgname=swiftly-bin
-pkgver=0.1.0
-pkgrel=2
+pkgver=0.2.0
+pkgrel=1
pkgdesc="A Swift toolchain installer and manager, written in Swift."
arch=('x86_64')
url="https://swift-server.github.io/swiftly/"
@@ -14,7 +14,7 @@ options=('!strip')
provides=(swift-language)
conflicts=(swift-language)
source=("https://github.com/swift-server/${_pkgname}/releases/download/${pkgver}/${_pkgname}-x86_64-unknown-linux-gnu")
-sha256sums=('b3ef4e3d652a622af8f5ec54c1264e0ad9de37fa26e81cfe70649833c0039e45')
+sha256sums=('e0e58f6cbd4ad60c4cd51eeed88c3e908b3e2951bf55bcd3799fdd66d0fddbf4')
install='swiftly-bin.install'
package() {
@@ -23,6 +23,6 @@ package() {
echo "{ \"platform\": { \"name\": \"centos7\", \"nameFull\": \"centos7\", \"namePretty\": \"Arch Linux\" }, \"installedToolchains\": [] }" > ~/.local/share/${_pkgname}/config.json # basic config.json setup
fi
install -D -m 0755 ${_pkgname}-x86_64-unknown-linux-gnu ${pkgdir}/usr/bin/${_pkgname}
- echo "Config and toolchains can be found in ~/.local/share/swiftly. Toolchains are installed to ~/.local/bin."
- echo "Please do not modify ~/.local/share/swiftly/toolchains. That directory should only be managed by swiftly itself."
+ echo "Config and toolchains can be found in ~/.local/share/${_pkgname}. Toolchains are installed to ~/.local/bin."
+ echo "If you encounter an error stating that config.json cannot be found, please do a clean build of this package."
}
diff --git a/swiftly-bin.install b/swiftly-bin.install
index 33a64d8f2eb7..e97ee9fb2dfb 100644
--- a/swiftly-bin.install
+++ b/swiftly-bin.install
@@ -1,14 +1,6 @@
pre_remove() {
echo "Removing all Swift installations..."
- echo "IF THERE ARE ANY FILES IN ~/.local/share/swiftly/toolchains THAT ARE NOT MANAGED BY SWIFTLY, PLEASE INTERRUPT THIS AND REMOVE THEM. IT WILL CAUSE AN INFINITE LOOP OTHERWISE."
- while true
- do
- if [ "$(ls -A /home/$SUDO_USER/.local/share/swiftly/toolchains)" ]; then
- runuser -l $SUDO_USER -c 'swiftly uninstall latest -y'
- else
- break
- fi
- done
+ runuser -l $SUDO_USER -c 'swiftly uninstall all -y'
}
post_remove() {