summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Maingot2022-01-18 23:30:13 -0800
committerJulian Maingot2022-01-18 23:30:13 -0800
commit2076602034b65c6c79262e995d0daaefb5ac413f (patch)
treef83214000463aab9294a57aebc32cab51ad0a6bc
parentf70c4af216b7aaa0a4d9d1f504e122decf9f2a38 (diff)
downloadaur-2076602034b65c6c79262e995d0daaefb5ac413f.tar.gz
Removed deprecated targets
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a531f64b97c..4515370de225 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = swiftshader-git
- pkgdesc = High-performance CPU-based implementation of the Vulkan, OpenGL ES, and Direct3D 9 graphics APIs
- pkgver = r4824.e7ce4e5391
+ pkgdesc = High-performance CPU-based implementation of the Vulkan graphics API12.
+ pkgver = r6374.2e74d5dc03
pkgrel = 1
url = https://swiftshader.googlesource.com/SwiftShader
arch = x86_64
@@ -12,8 +12,11 @@ pkgbase = swiftshader-git
provides = opengl-driver
provides = vulkan-driver
conflicts = swiftshader
- source = https://swiftshader.googlesource.com/SwiftShader
+ source = git+https://swiftshader.googlesource.com/SwiftShader#branch=master
+ source = git+https://github.com/google/googletest.git
+ source = git+https://github.com/ianlancetaylor/libbacktrace.git
+ sha1sums = SKIP
+ sha1sums = SKIP
sha1sums = SKIP
pkgname = swiftshader-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d77b7c164514..659eb6a10172 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=swiftshader-git
-pkgver=r4824.e7ce4e5391
+pkgver=r6374.2e74d5dc03
pkgrel=1
-pkgdesc='High-performance CPU-based implementation of the Vulkan, OpenGL ES, and Direct3D 9 graphics APIs'
+pkgdesc='High-performance CPU-based implementation of the Vulkan graphics API12.'
arch=(x86_64)
url=https://swiftshader.googlesource.com/SwiftShader
provides=(swiftshader libgl opengl-driver vulkan-driver)
@@ -25,9 +25,11 @@ pkgver() {
prepare() {
git -C SwiftShader submodule init
+ # this repo is not publicly accessible so we won't fetch it
+ git -C SwiftShader config submodule."third_party/git-hooks".update none
git -C SwiftShader config submodule."third_party/googletest".url "$srcdir/googletest"
git -C SwiftShader config submodule."third_party/libbacktrace/src".url "$srcdir/libbacktrace"
- git -C SwiftShader submodule update
+ git -C SwiftShader submodule update --depth=1
cmake \
-G Ninja \
@@ -55,9 +57,6 @@ package() {
install -dm755 "$pkgdir"/usr/lib
install -m755 -t "$pkgdir"/usr/lib \
- build/libEGL.so \
- build/libGLES_CM.so \
- build/libGLESv2.so \
build/libvk_swiftshader.so
install -dm755 "$pkgdir"/usr/share/vulkan/icd.d/