summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-04-22 20:52:23 +0800
committerzxp198210052023-04-22 20:52:23 +0800
commit19d838d44b2120e496fd3f31ec12a8bda449f896 (patch)
tree7624ea508363a7514771c20edf66c26927d748e4
parent3eb4c0a5923c3f8c2af73c7ea0f08a827a9f3034 (diff)
downloadaur-19d838d44b2120e496fd3f31ec12a8bda449f896.tar.gz
fix errors
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02b8d3ebbd12..0bc8c8b9504f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = swifty-bin
pkgdesc = Free Offline-first Password Manager for MacOS, Windows and Linux.
pkgver = 0.6.13
- pkgrel = 2
+ pkgrel = 3
url = https://getswifty.pro/
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index ae656b7db3de..45a0a0c9453f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-_pkgname=swifty
-pkgname="${_pkgname}-bin"
+pkgname="swifty-bin"
pkgver=0.6.13
-pkgrel=2
+pkgrel=3
pkgdesc="Free Offline-first Password Manager for MacOS, Windows and Linux."
arch=("x86_64")
url="https://getswifty.pro/"
@@ -10,12 +9,12 @@ _githuburl="https://github.com/swiftyapp/swifty"
license=('GPL3')
depends=(nss gtk3 at-spi2-core alsa-lib libxkbcommon libxdamage nspr libxfixes glib2 libx11 hicolor-icon-theme \
libxcomposite libcups pango cairo libxrandr libdrm mesa expat glibc libxext gcc-libs dbus libxcb)
-conflit=("${_pkgname}")
-provides=("${_pkgname}")
-source=("${_pkgname}-${pkgver}_amd64.deb::${_githuburl}/releases/download/v${pkgver}/Swifty_${pkgver}_amd64.deb")
+conflit=("${pkgname%-bin}" "${pkgname%-bin}-appimage")
+provides=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}_amd64.deb::${_githuburl}/releases/download/v${pkgver}/Swifty_${pkgver}_amd64.deb")
sha256sums=('daa037c75ebc4e6a7b0b835f0efef2d5b1fa7bf4c2c728badbeb16d5f61a3b6a')
package() {
bsdtar -xvf data.tar.xz -C "${pkgdir}"
- install -Dm644 "${pkgdir}/usr/share/icons/hicolor/0x0/apps/${_pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.png"
- rm -r "${pkgdir}/usr/share/icons/hicolor/0x0"
+ install -Dm644 "${pkgdir}/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ rm -r "${pkgdir}/usr/share/icons"
} \ No newline at end of file