summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-03-24 09:28:30 +0800
committerzxp198210052023-03-24 09:28:30 +0800
commit3eb4c0a5923c3f8c2af73c7ea0f08a827a9f3034 (patch)
treea73a413c2cd26a00def1b263d681002b31491878
parente07eec0497041d195344a48f41eceb0a0a7cd68c (diff)
downloadaur-3eb4c0a5923c3f8c2af73c7ea0f08a827a9f3034.tar.gz
fix errors
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD22
2 files changed, 34 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aaee973cb938..02b8d3ebbd12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,35 @@
pkgbase = swifty-bin
pkgdesc = Free Offline-first Password Manager for MacOS, Windows and Linux.
pkgver = 0.6.13
- pkgrel = 1
- url = https://github.com/swiftyapp/swifty
+ pkgrel = 2
+ url = https://getswifty.pro/
arch = x86_64
license = GPL3
depends = nss
depends = gtk3
depends = at-spi2-core
depends = alsa-lib
+ depends = libxkbcommon
+ depends = libxdamage
+ depends = nspr
+ depends = libxfixes
+ depends = glib2
+ depends = libx11
+ depends = hicolor-icon-theme
+ depends = libxcomposite
+ depends = libcups
+ depends = pango
+ depends = cairo
+ depends = libxrandr
+ depends = libdrm
+ depends = mesa
+ depends = expat
+ depends = glibc
+ depends = libxext
+ depends = gcc-libs
+ depends = dbus
+ depends = libxcb
+ provides = swifty
source = swifty-0.6.13_amd64.deb::https://github.com/swiftyapp/swifty/releases/download/v0.6.13/Swifty_0.6.13_amd64.deb
sha256sums = daa037c75ebc4e6a7b0b835f0efef2d5b1fa7bf4c2c728badbeb16d5f61a3b6a
diff --git a/PKGBUILD b/PKGBUILD
index fc2856b7d686..ae656b7db3de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname=swifty-bin
_pkgname=swifty
+pkgname="${_pkgname}-bin"
pkgver=0.6.13
-pkgrel=1
+pkgrel=2
pkgdesc="Free Offline-first Password Manager for MacOS, Windows and Linux."
arch=("x86_64")
-url="https://github.com/swiftyapp/swifty"
+url="https://getswifty.pro/"
+_githuburl="https://github.com/swiftyapp/swifty"
license=('GPL3')
-depends=(nss gtk3 at-spi2-core alsa-lib)
-conflit=(swifty swifty-appimage)
-provides=()
-options=()
-source=("${_pkgname}-${pkgver}_amd64.deb::${url}/releases/download/v${pkgver}/Swifty_${pkgver}_amd64.deb")
+depends=(nss gtk3 at-spi2-core alsa-lib libxkbcommon libxdamage nspr libxfixes glib2 libx11 hicolor-icon-theme \
+ libxcomposite libcups pango cairo libxrandr libdrm mesa expat glibc libxext gcc-libs dbus libxcb)
+conflit=("${_pkgname}")
+provides=("${_pkgname}")
+source=("${_pkgname}-${pkgver}_amd64.deb::${_githuburl}/releases/download/v${pkgver}/Swifty_${pkgver}_amd64.deb")
sha256sums=('daa037c75ebc4e6a7b0b835f0efef2d5b1fa7bf4c2c728badbeb16d5f61a3b6a')
package() {
bsdtar -xvf data.tar.xz -C "${pkgdir}"
- mkdir -p "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
- mv "${pkgdir}/usr/share/icons/hicolor/0x0/apps/${_pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.png"
+ install -Dm644 "${pkgdir}/usr/share/icons/hicolor/0x0/apps/${_pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.png"
rm -r "${pkgdir}/usr/share/icons/hicolor/0x0"
-}
+} \ No newline at end of file