summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranco Masotti2017-03-09 15:19:04 +0100
committerFranco Masotti2017-03-09 15:19:04 +0100
commit93587ca47cadf3bbd80db5e52880b547d9e0d818 (patch)
treed740c468f71a794c932423ec675f8207572d1881
parent7a1659085eea033b740cfa1b41a8044bf4d9a9c9 (diff)
downloadaur-93587ca47cadf3bbd80db5e52880b547d9e0d818.tar.gz
Updated to new version.
-rw-r--r--.SRCINFO12
-rw-r--r--.install4
-rw-r--r--PKGBUILD14
-rwxr-xr-xrun.sh4
4 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b63cef4f3735..4ce3bb2f5d8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = swish-cplint
pkgdesc = SWI-Prolog for SHaring: a SWI-Prolog web IDE integrated with the cplint suite
- pkgver = r1789.2563692
+ pkgver = r1849.519a5ac
pkgrel = 1
url = https://github.com/friguzzi/swish
install = .install
arch = x86_64
license = BSD
makedepends = git
+ makedepends = make
makedepends = bower
makedepends = sed
- depends = libxinerama
- depends = libxpm
+ depends = bash
+ depends = coreutils
+ depends = gawk
depends = git
depends = graphviz
- depends = swi-prolog-devel
+ depends = libxinerama
+ depends = libxpm
depends = rserve-sandbox-docker
+ depends = swi-prolog-devel
conflicts = swish
conflicts = swish-cplint-bin
source = git+https://github.com/friguzzi/swish#branch=master
diff --git a/.install b/.install
index c4aeefd3c07c..6902e56bc66e 100644
--- a/.install
+++ b/.install
@@ -1,8 +1,8 @@
post_install() {
# Add swish user and group with a home directory (which will contain all
# the packs).
- getent group swish &>/dev/null || groupadd -r swish >/dev/null
- getent passwd swish &>/dev/null || useradd -m -d /home/swish \
+ getent group swish 1>/dev/null 2>/dev/null || groupadd -r swish >/dev/null
+ getent passwd swish 1>/dev/null 2>/dev/null || useradd -m -d /home/swish \
-r -g swish swish >/dev/null
# Add swish user to the rserve group. If this is not done, access to the
diff --git a/PKGBUILD b/PKGBUILD
index 05cb9dfcb2e7..42f21745b599 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
# Maintainer: Franco Masotti <franco dot masotti at student dot unife dot it>
# Contributor: Franco Masotti <franco dot masotti at student dot unife dot it>
pkgname=swish-cplint
-pkgver=r1789.2563692
+pkgver=r1849.519a5ac
pkgrel=1
pkgdesc="SWI-Prolog for SHaring: a SWI-Prolog web IDE integrated with the cplint suite"
arch=('x86_64')
url="https://github.com/friguzzi/swish"
license=('BSD')
-depends=('libxinerama'
- 'libxpm'
+depends=('bash'
+ 'coreutils'
+ 'gawk'
'git'
'graphviz'
- 'swi-prolog-devel'
- 'rserve-sandbox-docker')
+ 'libxinerama'
+ 'libxpm'
+ 'rserve-sandbox-docker'
+ 'swi-prolog-devel')
makedepends=('git'
+ 'make'
'bower'
'sed')
conflicts=('swish'
diff --git a/run.sh b/run.sh
index 359f1e31d970..9bfaafe3d4e8 100755
--- a/run.sh
+++ b/run.sh
@@ -1,4 +1,4 @@
-#!/usr/bin/env sh
+#!/usr/bin/env bash
#
# run.sh
@@ -81,7 +81,7 @@ killd()
# kill action only if process exists.
if [ -f "$pid_file" ]; then
pid=$(cat "$pid_file")
- ps -q $pid > /dev/null
+ ps -p $pid > /dev/null
if [ $? -eq 0 ]; then
kill -s TERM $pid
fi