summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrnmst/Franco Masotti2016-12-27 23:28:21 +0100
committerfrnmst/Franco Masotti2016-12-27 23:28:21 +0100
commitef8f46da27b403ba37fed40bdbf156b930982085 (patch)
treef77a496a291eeea129cbad448e6c983f97f7cb63
parentf02e5142dafa48c5ceef467db55d4cb1c2548ab6 (diff)
downloadaur-ef8f46da27b403ba37fed40bdbf156b930982085.tar.gz
Updated.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xinstall_web_iface_deps.pl3
-rw-r--r--run.pl2
-rwxr-xr-xrun.sh8
5 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa86a643e425..197419919c57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = swish-cplint
pkgdesc = SWI-Prolog for SHaring: a SWI-Prolog web IDE integrated with the cplint suite
pkgver = r1673.4e5dd96
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/friguzzi/swish
install = .install
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = swish-cplint
depends = libxpm
depends = git
depends = graphviz
- depends = swi-prolog-devel
+ depends = swi-prolog-devel=7.3.32
depends = rserve-sandbox-docker
conflicts = swish
source = git+https://github.com/friguzzi/swish#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index e0c5f174bff7..a6cbe231e1c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Franco Masotti <franco dot masotti at student dot unife dot it>
pkgname=swish-cplint
pkgver=r1673.4e5dd96
-pkgrel=5
+pkgrel=6
pkgdesc="SWI-Prolog for SHaring: a SWI-Prolog web IDE integrated with the cplint suite"
arch=('x86_64')
url="https://github.com/friguzzi/swish"
@@ -11,7 +11,7 @@ depends=('libxinerama'
'libxpm'
'git'
'graphviz'
- 'swi-prolog-devel'
+ 'swi-prolog-devel=7.3.32'
'rserve-sandbox-docker')
makedepends=('git'
'bower'
diff --git a/install_web_iface_deps.pl b/install_web_iface_deps.pl
index 076c0b96e33f..dd8c78926c5f 100755
--- a/install_web_iface_deps.pl
+++ b/install_web_iface_deps.pl
@@ -32,7 +32,8 @@ install:-
pack_install(real, [url('http://stoics.org.uk/~nicos/sware/packs/real/real-2.0.tgz'),interactive(false)]),
pack_install(matrix, [url('https://github.com/friguzzi/matrix.git'),interactive(false)]),
pack_install(cplint, [url('https://github.com/friguzzi/cplint.git'),interactive(false)]),
- pack_install('rserve_client', [url('https://github.com/JanWielemaker/rserve_client.git'),interactive(false)]).
+ pack_install('rserve_client', [url('https://github.com/JanWielemaker/rserve_client.git'),interactive(false)]),
+ pack_install('cplint_r', [url('https://github.com/frnmst/cplint_r.git'),interactive(false)]).
main:-
catch(install, E, (print_message(error, E), fail)),
diff --git a/run.pl b/run.pl
index 63372c37d5ec..c1252e1f2457 100644
--- a/run.pl
+++ b/run.pl
@@ -26,7 +26,7 @@
*/
:- use_module(server).
-:- use_module(lib/r_swish).
+:- use_module('lib/r_swish').
:- use_module(library(r/r_sandbox)).
% Using `localhost:3050`, we only bind to localhost interface!
diff --git a/run.sh b/run.sh
index 26c502d1e399..359f1e31d970 100755
--- a/run.sh
+++ b/run.sh
@@ -88,6 +88,11 @@ killd()
fi
}
+remove()
+{
+ :
+}
+
startd()
{
local pid=""
@@ -155,11 +160,12 @@ write_pid_file()
option_parser()
{
- getopts ":hiks" opt "$@"
+ getopts ":hikrs" opt "$@"
case "$opt" in
h ) help ;;
i ) init ;;
k ) killd ;;
+ r ) remove ;;
s ) startd ;;
? ) help; return 1 ;;
esac