summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUltracoolguy2019-04-19 10:14:51 -0400
committerUltracoolguy2019-04-19 10:14:51 -0400
commit3da6a8b2c965c17ed0c798112b0bec0044e104e4 (patch)
treec0980efd1a11eb64fc6b324c84404928a3075633
parentb2a13cb5849e0907c63bdbdc91406c7e76e61ef8 (diff)
downloadaur-3da6a8b2c965c17ed0c798112b0bec0044e104e4.tar.gz
Fixed some newbie mistakes and some optimizations
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
2 files changed, 17 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6892d959c7df..a577fd8c0b29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
-pkgbase = switch-lan-play
+pkgbase = switch-lan-play-git
pkgdesc = A program for connecting to fanmade Nintendo Switch servers--see url for more info
- pkgver = git
- pkgrel = 1
+ pkgver = v0.1.0.r4.f62bf0c
+ pkgrel = 1.2
epoch = 0
url = https://github.com/spacemeowx2/switch-lan-play
arch = any
license = GPL3
makedepends = cmake
- depends = libpcap
- source = https://github.com/spacemeowx2/switch-lan-play.git
+ source = switch-lan-play::git+https://github.com/spacemeowx2/switch-lan-play.git
md5sums = SKIP
-pkgname = switch-lan-play
+pkgname = switch-lan-play-git
diff --git a/PKGBUILD b/PKGBUILD
index db4d4a454ce8..308045b1b361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Ultracoolguy <dummyd241 at gmaildotcom>
-pkgname="switch-lan-play"
-pkgver=git
-pkgrel=1
+pkgname="switch-lan-play-git"
+pkgver=v0.1.0.r4.f62bf0c
+pkgrel=1.2
epoch=0
pkgdesc="A program for connecting to fanmade Nintendo Switch servers--see url for more info"
arch=(any)
url="https://github.com/spacemeowx2/switch-lan-play"
license=('GPL3')
groups=()
-depends=(libpcap)
+deplaypends=(libpcap)
makedepends=(cmake)
checkdepends=()
optdepends=()
@@ -19,34 +19,29 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/spacemeowx2/switch-lan-play.git")
+source=('switch-lan-play::git+https://github.com/spacemeowx2/switch-lan-play.git')
noextract=()
md5sums=('SKIP')
+gitname=switch-lan-play
+
pkgver() {
- cd switch-lan-play
+ cd $gitname
git describe --tags | sed 's/-/.r/; s/-g/./'
}
-
-prepare() {
- echo "Executing if"
- if [[ -d switch-lan-play ]];then
- rm -rf switch-lan-play
- fi
- git clone $source
-}
-
build() {
- cd switch-lan-play
+ cd $gitname
+ if [[ ! -d build ]] ;then
mkdir build
+ fi
cd build
cmake -DCMAKE_BUILD_TYPE=Release ..
make
}
package() {
- cd switch-lan-play/build
+ cd $gitname/build
make DESTDIR="$pkgdir/" install
}