summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUltracoolguy2019-04-18 10:45:19 -0400
committerUltracoolguy2019-04-18 10:45:19 -0400
commit49410b588cfb89054e9aad95274c381df0312075 (patch)
treefb4b5123c1d0078cb33cc448b8f128cb30bca339
downloadaur-49410b588cfb89054e9aad95274c381df0312075.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD52
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de4ece8ae533
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = switch-lan-play
+ pkgdesc = A program for connecting to switch-lan-play servers-see url for more info
+ pkgver = v0.1.0.r4.f62bf0c
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/spacemeowx2/switch-lan-play
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ depends = libpcap
+ source = https://github.com/spacemeowx2/switch-lan-play.git
+ md5sums = SKIP
+
+pkgname = switch-lan-play
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8e61b4e4082
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Ultracoolguy <dummyd241 at gmaildotcom>
+pkgname="switch-lan-play"
+pkgver=v0.1.0.r4.f62bf0c
+pkgrel=1
+epoch=0
+pkgdesc="A program for connecting to switch-lan-play servers-see url for more info"
+arch=(any)
+url="https://github.com/spacemeowx2/switch-lan-play"
+license=('GPL3')
+groups=()
+depends=(libpcap)
+makedepends=(cmake)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/spacemeowx2/switch-lan-play.git")
+noextract=()
+md5sums=('SKIP')
+pkgver() {
+ cd switch-lan-play
+
+ git describe --tags | sed 's/-/.r/; s/-g/./'
+
+}
+
+
+prepare() {
+ echo "Executing if"
+ if [[ -d switch-lan-play ]];then
+ rm -rf switch-lan-play
+ fi
+ git clone $source
+}
+
+build() {
+ cd switch-lan-play
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+package() {
+ cd switch-lan-play/build
+ make DESTDIR="$pkgdir/" install
+}
+