summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUltracoolguy2019-07-18 11:20:27 -0400
committerUltracoolguy2019-07-18 11:20:27 -0400
commit4eaf5501532960d4f592b146d9390a8ef97e6c7f (patch)
tree6b3456a13aa1402cf4d10f1ed7708166e919a484
parentd90e7f97d8deb30bce2fd5f9410251ed17a81ab5 (diff)
downloadaur-4eaf5501532960d4f592b146d9390a8ef97e6c7f.tar.gz
This is embarrasing...fixed a newbie bug
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb461b96d4c8..2a88b5253626 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = switch-lan-play
pkgdesc = A program for connecting to switch-lan-play servers-see url for more info
- pkgver = v0.1.0.r36.787a27d
- pkgrel = 1.3
+ pkgver = v0.1.0.r36.g787a27d
+ pkgrel = 1
epoch = 0
url = https://github.com/spacemeowx2/switch-lan-play
arch = any
license = GPL3
makedepends = cmake
depends = libpcap
- source = switch-lan-play::https://github.com/spacemeowx2/switch-lan-play.git
+ source = switch-lan-play::git+https://github.com/spacemeowx2/switch-lan-play
md5sums = SKIP
pkgname = switch-lan-play
diff --git a/PKGBUILD b/PKGBUILD
index 9363c3b2d551..edba45e42796 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ultracoolguy <dummyd241 at gmaildotcom>
pkgname="switch-lan-play"
-pkgver=v0.1.0.r36.787a27d
-pkgrel=1.3
+pkgver=v0.1.0.r36.g787a27d
+pkgrel=1
epoch=0
pkgdesc="A program for connecting to switch-lan-play servers-see url for more info"
arch=(any)
@@ -19,27 +19,28 @@ backup=()
options=()
install=
changelog=
-source=("$pkgname::${url}.git")
+source=("$pkgname::git+${url}")
noextract=()
md5sums=('SKIP')
-pkgver() {
- cd switch-lan-play
-
- git describe --tags | sed 's/-/.r/; s/-g/./'
+#Taken from this forum https://bbs.archlinux.org/viewtopic.php?id=230826
+ pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- if [[ -d switch-lan-play ]];then
- rm -rf switch-lan-play
- fi
- git clone $source
+ cd $pkgname
+ git submodule init
+ git submodule update --init --recursive
}
+
+
build() {
- cd switch-lan-play
- mkdir build
+ cd $pkgname
+ mkdir -p build
cd build
cmake -DCMAKE_BUILD_TYPE=Release ..
make