summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCédric Connes2019-12-30 22:34:33 +0100
committerCédric Connes2019-12-30 22:34:33 +0100
commitf310e1632d049cf7f75e064d58d0ede6d2232f89 (patch)
treeeca47cdba0b19be3133be5fc57770aad4e545e81
parentc75d67a30ad8d594d1029f46070c068c9dc60d24 (diff)
downloadaur-f310e1632d049cf7f75e064d58d0ede6d2232f89.tar.gz
Stick to official releases
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD64
3 files changed, 28 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 297f3215befc..d99353944984 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = switch-lan-play
- pkgdesc = A program for connecting to switch-lan-play servers-see url for more info
- pkgver = v0.2.1.r0.g1c26ca6
+ pkgdesc = Make you and your friends play games like in a LAN
+ pkgver = 0.2.1
pkgrel = 1
- epoch = 0
url = https://github.com/spacemeowx2/switch-lan-play
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL3
makedepends = cmake
depends = libpcap
- source = switch-lan-play::git+https://github.com/spacemeowx2/switch-lan-play
- md5sums = SKIP
+ source = git+https://github.com/spacemeowx2/switch-lan-play.git#tag=v0.2.1
+ sha256sums = SKIP
pkgname = switch-lan-play
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 6e372f80e7c7..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-/src
-/switch-lan-play-git
-/pkg
-switch-lan-play-*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index fe389b561262..936daf197e31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,32 @@
-# Maintainer: Ultracoolguy <dummyd241 at gmaildotcom>
-pkgname="switch-lan-play-git"
-pkgver=v0.2.1.r23.g200e767
+# Maintainer: base64 --decode <<< Q8OpZHJpYyBDb25uZXMgPGNlZHJpYy5jb25uZXNAZ21haWwuY29tPgo=
+
+pkgname=switch-lan-play
+pkgver=0.2.1
pkgrel=1
-epoch=0
-pkgdesc="A program for connecting to switch-lan-play servers-see url for more info"
-arch=(any)
-url="https://github.com/spacemeowx2/switch-lan-play"
+pkgdesc='Make you and your friends play games like in a LAN'
+arch=('i686' 'x86_64')
+url='https://github.com/spacemeowx2/switch-lan-play'
license=('GPL3')
-groups=()
-depends=("libpcap")
-makedepends=("cmake")
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=("switch-lan-play")
-backup=()
-options=()
-install=
-changelog=
-source=("$pkgname::git+${url}")
-noextract=()
-md5sums=('SKIP')
+depends=('libpcap')
+makedepends=('cmake')
+source=("git+https://github.com/spacemeowx2/$pkgname.git#tag=v$pkgver")
+sha256sums=('SKIP')
-#Taken from this forum https://bbs.archlinux.org/viewtopic.php?id=230826
- pkgver() {
+prepare() {
cd "$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git submodule update --init --recursive
}
-
-prepare() {
- cd $pkgname
- git submodule init
- git submodule update --init --recursive
+build() {
+ cd "$pkgname"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+ make
}
-
-
-build() {
- cd $pkgname
- mkdir -p build
- cd build
- cmake -DCMAKE_BUILD_TYPE=Release ..
- make
-}
package() {
- cd $pkgname/build
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname"
+ cd build
+ make DESTDIR="$pkgdir/" install
}
-