summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUltracoolguy2019-12-13 14:58:01 -0400
committerUltracoolguy2019-12-13 14:58:01 -0400
commitf90877e45fa6888bd922b9525eb6a5b067b9a014 (patch)
tree9586f6d2983aeb65d660ff930af317266bbf411b
downloadaur-f90877e45fa6888bd922b9525eb6a5b067b9a014.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD52
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c76e7fa18b64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = switch-lan-play-git
+ pkgdesc = A program for connecting to switch-lan-play servers-see url for more info
+ pkgver = v0.2.1.r23.g200e767
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/spacemeowx2/switch-lan-play
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ depends = libpcap
+ replaces = switch-lan-play
+ source = switch-lan-play-git::git+https://github.com/spacemeowx2/switch-lan-play
+ md5sums = SKIP
+
+pkgname = switch-lan-play-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4b4c3e51792a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+switch-lan-play-git/
+*.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe389b561262
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Ultracoolguy <dummyd241 at gmaildotcom>
+pkgname="switch-lan-play-git"
+pkgver=v0.2.1.r23.g200e767
+pkgrel=1
+epoch=0
+pkgdesc="A program for connecting to switch-lan-play servers-see url for more info"
+arch=(any)
+url="https://github.com/spacemeowx2/switch-lan-play"
+license=('GPL3')
+groups=()
+depends=("libpcap")
+makedepends=("cmake")
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=("switch-lan-play")
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname::git+${url}")
+noextract=()
+md5sums=('SKIP')
+
+#Taken from this forum https://bbs.archlinux.org/viewtopic.php?id=230826
+ pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+prepare() {
+ cd $pkgname
+ git submodule init
+ git submodule update --init --recursive
+}
+
+
+
+build() {
+ cd $pkgname
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+package() {
+ cd $pkgname/build
+ make DESTDIR="$pkgdir/" install
+}
+