summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-03-27 11:50:29 +0200
committerMaxime Gauduin2018-03-27 11:50:29 +0200
commit76ebefcc7b6a8dd0a06c044ec4cefe20ecaa14fd (patch)
tree984559825299f18eba676f4833efc5c1f230f703
parent9035c9e24092d12f34bcea2aeef189e6fd68ae03 (diff)
downloadaur-76ebefcc7b6a8dd0a06c044ec4cefe20ecaa14fd.tar.gz
Switch to meson
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2affed4a6c0c..aa1b3f36b818 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
# Generated by mksrcinfo v8
-# Mon May 8 12:55:05 UTC 2017
+# Tue Mar 27 09:50:21 UTC 2018
pkgbase = switchboard-plug-a11y-git
pkgdesc = Switchboard Universal Access Plug
- pkgver = r158.f7621ec
+ pkgver = r217.bc242d1
pkgrel = 1
url = https://github.com/elementary/switchboard-plug-a11y
- arch = i686
arch = x86_64
groups = pantheon-unstable
license = GPL3
- makedepends = cmake
makedepends = git
makedepends = granite-git
+ makedepends = meson
makedepends = switchboard-git
makedepends = vala
depends = glib2
diff --git a/PKGBUILD b/PKGBUILD
index 59abbac2815c..de72b9298df7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-plug-a11y-git
-pkgver=r158.f7621ec
+pkgver=r217.bc242d1
pkgrel=1
pkgdesc='Switchboard Universal Access Plug'
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('GPL3')
groups=('pantheon-unstable')
depends=('glib2' 'glibc' 'gtk3' 'libgee'
'libgranite.so' 'libswitchboard-2.0.so')
-makedepends=('cmake' 'git' 'granite-git' 'switchboard-git' 'vala')
+makedepends=('git' 'granite-git' 'meson' 'switchboard-git' 'vala')
provides=('switchboard-plug-a11y')
conflicts=('switchboard-plug-a11y')
source=('git+https://github.com/elementary/switchboard-plug-a11y.git')
@@ -23,8 +23,6 @@ pkgver() {
}
prepare() {
- cd switchboard-plug-a11y
-
if [[ -d build ]]; then
rm -rf build
fi
@@ -32,19 +30,16 @@ prepare() {
}
build() {
- cd switchboard-plug-a11y/build
+ cd build
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib'
- make
+ arch-meson ../switchboard-plug-a11y
+ ninja
}
package() {
- cd switchboard-plug-a11y/build
+ cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
}
# vim: ts=2 sw=2 et: