summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-09-11 10:14:27 +0200
committerMaxime Gauduin2015-09-11 10:14:27 +0200
commit315b0d7df770d9ca8979357647d4ff406251bbe1 (patch)
treee64ba8a3478a0276f237578fb6a64601f64725fa
downloadaur-315b0d7df770d9ca8979357647d4ff406251bbe1.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--MKPKG4
-rw-r--r--PKGBUILD42
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ce1cccbbbcb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = switchboard-plug-applications
+ pkgdesc = Applications plug for Switchboard
+ pkgver = 0.1.0.1
+ pkgrel = 1
+ url = https://launchpad.net/switchboard-plug-applications
+ arch = i686
+ arch = x86_64
+ groups = pantheon
+ license = GPL3
+ makedepends = cmake
+ makedepends = vala
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgee
+ depends = libswitchboard-2.0.so
+ source = https://launchpad.net/switchboard-plug-applications/freya/0.1.0.1/+download/switchboard-plug-applications-0.1.0.1.tar.xz
+ sha256sums = f8836aa3b3cd852e13313843ea8e7b2b41a7aa230169dc0236ae6bf055cfa8ee
+
+pkgname = switchboard-plug-applications
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..f9dd864dbd2e
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,4 @@
+pkgname=('switchboard-plug-applications')
+builddeps=('switchboard')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae0805a93b08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=switchboard-plug-applications
+pkgver=0.1.0.1
+pkgrel=1
+pkgdesc='Applications plug for Switchboard'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/switchboard-plug-applications'
+license=('GPL3')
+groups=('pantheon')
+depends=('gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libgee'
+ 'libswitchboard-2.0.so')
+makedepends=('cmake' 'vala')
+source=("https://launchpad.net/switchboard-plug-applications/freya/${pkgver}/+download/switchboard-plug-applications-${pkgver}.tar.xz")
+sha256sums=('f8836aa3b3cd852e13313843ea8e7b2b41a7aa230169dc0236ae6bf055cfa8ee')
+
+prepare() {
+ cd switchboard-plug-applications-${pkgver}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd switchboard-plug-applications-${pkgver}/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd switchboard-plug-applications-${pkgver}/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: