summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-03-22 22:47:36 +0100
committerMaxime Gauduin2017-03-22 22:47:36 +0100
commitfa397981f9c9546b3d980ae36bdbb08d685d30ba (patch)
treef4bf0a497141451be0361826b8585d40aa507f65
downloadaur-fa397981f9c9546b3d980ae36bdbb08d685d30ba.tar.gz
Add switchboard-plug-bluetooth
-rw-r--r--.SRCINFO25
-rw-r--r--MKPKG4
-rw-r--r--PKGBUILD42
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6097b4fc1944
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Wed Mar 22 21:47:36 UTC 2017
+pkgbase = switchboard-plug-bluetooth
+ pkgdesc = Network plug for Switchboard
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://launchpad.net/switchboard-plug-bluetooth
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = bzr
+ makedepends = cmake
+ makedepends = vala
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgee
+ depends = wingpanel-indicator-bluetooth
+ depends = libswitchboard-2.0.so
+ source = https://launchpad.net/switchboard-plug-bluetooth/loki/0.1/+download/switchboard-plug-bluetooth-0.1.tar.xz
+ sha256sums = d8e63253ca62cd8d739ed5c3178ee51da68baa766358a80bbcc5bc0c8c201698
+
+pkgname = switchboard-plug-bluetooth
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..3b8f1d0164ce
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,4 @@
+pkgname=('switchboard-plug-bluetooth')
+builddeps=('switchboard' 'wingpanel' 'wingpanel-indicator-bluetooth')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d35badd66cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=switchboard-plug-bluetooth
+pkgver=0.1
+pkgrel=1
+pkgdesc='Network plug for Switchboard'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/switchboard-plug-bluetooth'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('glib2' 'glibc' 'gtk3' 'libgee' 'wingpanel-indicator-bluetooth'
+ 'libswitchboard-2.0.so')
+makedepends=('bzr' 'cmake' 'vala')
+source=("https://launchpad.net/switchboard-plug-bluetooth/loki/${pkgver}/+download/switchboard-plug-bluetooth-${pkgver}.tar.xz")
+sha256sums=('d8e63253ca62cd8d739ed5c3178ee51da68baa766358a80bbcc5bc0c8c201698')
+
+prepare() {
+ cd switchboard-plug-bluetooth-${pkgver}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd switchboard-plug-bluetooth-${pkgver}/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd switchboard-plug-bluetooth-${pkgver}/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: