summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-08-14 12:04:12 -0400
committerSolomon Choina2020-08-14 12:04:12 -0400
commitae185115a419c3234db256c427e8ea8650f72d3c (patch)
treef61231badfec1b82a59c2bd590a1961c3342ab21
parentfbc334dd49aa542f42d9ffd0f3ae94a95b2ac847 (diff)
downloadaur-ae185115a419c3234db256c427e8ea8650f72d3c.tar.gz
nicer pkgver and PKGBUILD
-rw-r--r--PKGBUILD25
1 files changed, 7 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b96503709944..b83ae2101798 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-plug-bluetooth-git
-pkgver=r155.c4b2478
+pkgver=2.3.2.r8.g7a56fd1
pkgrel=1
pkgdesc='Switchboard Bluetooth Plug'
arch=('x86_64')
@@ -9,8 +9,8 @@ url='https://github.com/elementary/switchboard-plug-bluetooth'
license=('GPL3')
groups=('pantheon-unstable')
depends=('bluez' 'glib2' 'glibc' 'gtk3' 'libgee'
- 'libswitchboard-2.0.so')
-makedepends=('git' 'granite-git' 'meson' 'switchboard-git' 'vala')
+ 'libswitchboard-2.0.so' 'libgranite.so')
+makedepends=('git' 'granite' 'meson' 'switchboard-git' 'vala')
provides=('switchboard-plug-bluetooth')
conflicts=('switchboard-plug-bluetooth')
replaces=('switchboard-plug-bluetooth-bzr')
@@ -20,27 +20,16 @@ sha256sums=('SKIP')
pkgver() {
cd switchboard-plug-bluetooth
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd build
-
- arch-meson ../switchboard-plug-bluetooth
- ninja
+ arch-meson switchboard-plug-bluetooth build
+ ninja -C build
}
package() {
- cd build
-
- DESTDIR="${pkgdir}" ninja install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et: