summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-08-17 21:08:45 -0400
committerSolomon Choina2020-08-17 21:08:45 -0400
commit2c4baa72e56b69cc7b0efe6124b4b136c7784049 (patch)
treeb4bb2aa9dc7545dd72de1d7ff66a9f9cf9883567
parent07dbccd2fccb88f6c5248724c817080b4970e663 (diff)
downloadaur-2c4baa72e56b69cc7b0efe6124b4b136c7784049.tar.gz
normal switchboard, normal granite and updpkgver
-rw-r--r--PKGBUILD23
1 files changed, 6 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 694e65aca663..c9265b21b736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-plug-datetime-git
-pkgver=r350.1b77520
+pkgver=2.1.9.r15.g3467949
pkgrel=1
pkgdesc='Switchboard Date & Time Plug'
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('GPL3')
groups=('pantheon-unstable')
depends=('cairo' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libgee'
'libgranite.so' 'libswitchboard-2.0.so')
-makedepends=('git' 'granite-git' 'meson' 'switchboard-git' 'vala')
+makedepends=('git' 'granite' 'meson' 'switchboard' 'vala')
provides=('switchboard-plug-datetime')
conflicts=('switchboard-plug-datetime')
source=('git+https://github.com/elementary/switchboard-plug-datetime.git')
@@ -19,27 +19,16 @@ sha256sums=('SKIP')
pkgver() {
cd switchboard-plug-datetime
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd build
-
- arch-meson ../switchboard-plug-datetime
- ninja
+ arch-meson switchboard-plug-datetime build
+ ninja -C build
}
package() {
- cd build
-
- DESTDIR="${pkgdir}" ninja install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et: