summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-01 22:57:11 +0200
committerMaxime Gauduin2017-05-01 22:57:11 +0200
commit612cde99d64f7bcffd67dc774b74c85e3796ff6d (patch)
treecf280ad0504c013149d42948b6231f0ccd000dd6
downloadaur-612cde99d64f7bcffd67dc774b74c85e3796ff6d.tar.gz
Add switchboard-plug-datetime-git
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD51
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4506733fac2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Mon May 1 20:57:11 UTC 2017
+pkgbase = switchboard-plug-datetime-git
+ pkgdesc = Switchboard Date & Time Plug
+ pkgver = r236.df62aaa
+ pkgrel = 1
+ url = https://github.com/elementary/switchboard-plug-datetime
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = granite-git
+ makedepends = switchboard-git
+ makedepends = vala
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgee
+ depends = libgranite.so
+ depends = libswitchboard-2.0.so
+ provides = switchboard-plug-datetime
+ conflicts = switchboard-plug-datetime-bzr
+ source = git+https://github.com/elementary/switchboard-plug-datetime.git
+ sha256sums = SKIP
+
+pkgname = switchboard-plug-datetime-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5540d86efc95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=switchboard-plug-datetime-git
+pkgver=r236.df62aaa
+pkgrel=1
+pkgdesc='Switchboard Date & Time Plug'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/switchboard-plug-datetime'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('cairo' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libgee'
+ 'libgranite.so' 'libswitchboard-2.0.so')
+makedepends=('cmake' 'git' 'granite-git' 'switchboard-git' 'vala')
+provides=('switchboard-plug-datetime')
+conflicts=('switchboard-plug-datetime')
+conflicts=('switchboard-plug-datetime-bzr')
+source=('git+https://github.com/elementary/switchboard-plug-datetime.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd switchboard-plug-datetime
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd switchboard-plug-datetime
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd switchboard-plug-datetime/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd switchboard-plug-datetime/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: