summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-04-26 09:38:17 +0200
committerMaxime Gauduin2018-04-26 09:38:17 +0200
commit4de8993c48d439ecaaa9fd1d5347ab314e1b75ce (patch)
tree024f8ab0f845f9ff634d90b6c5b9fc372532ea14
parent6233c38cae4c21e23a9e1e16f0d6cdb519dfb9fb (diff)
downloadaur-4de8993c48d439ecaaa9fd1d5347ab314e1b75ce.tar.gz
Switch to meson
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD29
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab76ae604cd5..129dbc0b1164 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Apr 26 07:38:16 UTC 2018
pkgbase = switchboard-plug-desktop-git
pkgdesc = Switchboard Desktop Plug
- pkgver = r803.6d5d8ee
+ pkgver = r870.5b0826a
pkgrel = 1
url = https://github.com/elementary/switchboard-plug-pantheon-shell
arch = x86_64
groups = pantheon-unstable
license = GPL3
- makedepends = cmake
makedepends = git
makedepends = granite-git
makedepends = libgexiv2
+ makedepends = meson
makedepends = switchboard-git
makedepends = vala
depends = gdk-pixbuf2
@@ -24,7 +26,6 @@ pkgbase = switchboard-plug-desktop-git
depends = libswitchboard-2.0.so
provides = switchboard-plug-desktop
conflicts = switchboard-plug-desktop
- replaces = switchboard-plug-desktop-bzr
source = switchboard-plug-desktop::git+https://github.com/elementary/switchboard-plug-pantheon-shell.git
source = switchboard-plug-desktop-paths.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7c17b898935e..0f954fc79f09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-plug-desktop-git
-pkgver=r803.6d5d8ee
+pkgver=r870.5b0826a
pkgrel=1
pkgdesc='Switchboard Desktop Plug'
arch=('x86_64')
@@ -11,10 +11,9 @@ groups=('pantheon-unstable')
depends=('gdk-pixbuf2' 'glib2' 'glibc' 'gnome-desktop' 'gtk3' 'libgee'
'libgexiv2' 'plank'
'libgranite.so' 'libswitchboard-2.0.so')
-makedepends=('cmake' 'git' 'granite-git' 'libgexiv2' 'switchboard-git' 'vala')
+makedepends=('git' 'granite-git' 'libgexiv2' 'meson' 'switchboard-git' 'vala')
provides=('switchboard-plug-desktop')
conflicts=('switchboard-plug-desktop')
-replaces=('switchboard-plug-desktop-bzr')
source=('switchboard-plug-desktop::git+https://github.com/elementary/switchboard-plug-pantheon-shell.git'
'switchboard-plug-desktop-paths.patch')
sha256sums=('SKIP'
@@ -27,31 +26,27 @@ pkgver() {
}
prepare() {
- cd switchboard-plug-desktop
-
- patch -Np1 -i ../switchboard-plug-desktop-paths.patch
-
if [[ -d build ]]; then
rm -rf build
fi
mkdir build
+
+ cd switchboard-plug-desktop
+
+ patch -Np1 -i ../switchboard-plug-desktop-paths.patch
}
build() {
- cd switchboard-plug-desktop/build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
- -DCMAKE_INSTALL_LIBEXECDIR='/usr/lib'
- make
+ cd build
+
+ arch-meson ../switchboard-plug-desktop
+ ninja
}
package() {
- cd switchboard-plug-desktop/build
+ cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
}
# vim: ts=2 sw=2 et: