summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-01 23:02:20 +0200
committerMaxime Gauduin2017-05-01 23:02:20 +0200
commit64629cbdfa1ba5e56e646165b8fe88c94d6a7d48 (patch)
tree7868c889342380650b25ca5e52e5492a009ba393
downloadaur-64629cbdfa1ba5e56e646165b8fe88c94d6a7d48.tar.gz
Add switchboard-plug-desktop-git
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD55
-rw-r--r--switchboard-plug-desktop-paths.patch12
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38f2d8dc138b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+# Generated by mksrcinfo v8
+# Mon May 1 21:02:20 UTC 2017
+pkgbase = switchboard-plug-desktop-git
+ pkgdesc = Switchboard Desktop Plug
+ pkgver = r741.c6dfa43
+ pkgrel = 1
+ url = https://github.com/elementary/switchboard-plug-pantheon-shell
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = granite-git
+ makedepends = switchboard-git
+ makedepends = vala
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gnome-desktop
+ depends = gtk3
+ depends = libgee
+ depends = plank
+ depends = libgranite.so
+ depends = libswitchboard-2.0.so
+ provides = switchboard-plug-desktop
+ conflicts = switchboard-plug-desktop
+ replaces = switchboard-plug-desktop-bzr
+ source = switchboard-plug-desktop::git+https://github.com/elementary/switchboard-plug-pantheon-shell.git
+ source = switchboard-plug-desktop-paths.patch
+ sha256sums = SKIP
+ sha256sums = 75353594da255ecc16b277e65f7a2bdc1a0aef17e6ab30a0be7b8636d60379c5
+
+pkgname = switchboard-plug-desktop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ad27f32b963
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=switchboard-plug-desktop-git
+pkgver=r741.c6dfa43
+pkgrel=1
+pkgdesc='Switchboard Desktop Plug'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/switchboard-plug-pantheon-shell'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('gdk-pixbuf2' 'glib2' 'glibc' 'gnome-desktop' 'gtk3' 'libgee' 'plank'
+ 'libgranite.so' 'libswitchboard-2.0.so')
+makedepends=('cmake' 'git' 'granite-git' 'switchboard-git' 'vala')
+provides=('switchboard-plug-desktop')
+conflicts=('switchboard-plug-desktop')
+replaces=('switchboard-plug-desktop-bzr')
+source=('switchboard-plug-desktop::git+https://github.com/elementary/switchboard-plug-pantheon-shell.git'
+ 'switchboard-plug-desktop-paths.patch')
+sha256sums=('SKIP'
+ '75353594da255ecc16b277e65f7a2bdc1a0aef17e6ab30a0be7b8636d60379c5')
+
+pkgver() {
+ cd switchboard-plug-desktop
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd switchboard-plug-desktop
+
+ patch -Np1 -i ../switchboard-plug-desktop-paths.patch
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd switchboard-plug-desktop/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd switchboard-plug-desktop/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/switchboard-plug-desktop-paths.patch b/switchboard-plug-desktop-paths.patch
new file mode 100644
index 000000000000..67fd4ac369af
--- /dev/null
+++ b/switchboard-plug-desktop-paths.patch
@@ -0,0 +1,12 @@
+diff -rupN switchboard-plug-desktop.orig/src/Views/Wallpaper.vala switchboard-plug-desktop/src/Views/Wallpaper.vala
+--- switchboard-plug-desktop.orig/src/Views/Wallpaper.vala 2016-12-20 14:13:11.207917562 +0100
++++ switchboard-plug-desktop/src/Views/Wallpaper.vala 2016-12-20 14:13:47.472669721 +0100
+@@ -81,7 +81,7 @@ public class Wallpaper : Gtk.EventBox {
+ // name of the default-wallpaper-link that we can prevent loading it again
+ // (assumes that the defaultwallpaper is also in the system wallpaper directory)
+ static string DEFAULT_LINK = "file://%s/elementaryos-default".printf (SYSTEM_BACKGROUNDS_PATH);
+- const string SYSTEM_BACKGROUNDS_PATH = "/usr/share/backgrounds";
++ const string SYSTEM_BACKGROUNDS_PATH = "/usr/share/backgrounds/pantheon";
+
+ public Switchboard.Plug plug { get; construct set; }
+ private GLib.Settings settings;