summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2019-03-04 11:48:56 +0100
committerMaxime Gauduin2019-03-04 11:48:56 +0100
commit781e0316b241e972bda141fe4f6e4b927ad87d67 (patch)
treeafec66ff60b9418eb4a0ab9e7afc096689130f2d
parent4de8993c48d439ecaaa9fd1d5347ab314e1b75ce (diff)
downloadaur-781e0316b241e972bda141fe4f6e4b927ad87d67.tar.gz
update desktop plug
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD63
-rw-r--r--switchboard-plug-desktop-paths.patch12
3 files changed, 37 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 129dbc0b1164..0fc8ba6d505a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Apr 26 07:38:16 UTC 2018
+# Mon Mar 4 10:48:56 UTC 2019
pkgbase = switchboard-plug-desktop-git
pkgdesc = Switchboard Desktop Plug
- pkgver = r870.5b0826a
+ pkgver = r1039.473a199
pkgrel = 1
url = https://github.com/elementary/switchboard-plug-pantheon-shell
arch = x86_64
@@ -16,20 +16,18 @@ pkgbase = switchboard-plug-desktop-git
makedepends = vala
depends = gdk-pixbuf2
depends = glib2
- depends = glibc
depends = gnome-desktop
depends = gtk3
depends = libgee
depends = libgexiv2
- depends = plank
depends = libgranite.so
depends = libswitchboard-2.0.so
+ depends = plank
+ depends = tumbler
provides = switchboard-plug-desktop
conflicts = switchboard-plug-desktop
source = switchboard-plug-desktop::git+https://github.com/elementary/switchboard-plug-pantheon-shell.git
- source = switchboard-plug-desktop-paths.patch
sha256sums = SKIP
- sha256sums = 75353594da255ecc16b277e65f7a2bdc1a0aef17e6ab30a0be7b8636d60379c5
pkgname = switchboard-plug-desktop-git
diff --git a/PKGBUILD b/PKGBUILD
index 0f954fc79f09..f7d29530b657 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,37 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-plug-desktop-git
-pkgver=r870.5b0826a
+pkgver=r1039.473a199
pkgrel=1
pkgdesc='Switchboard Desktop Plug'
-arch=('x86_64')
-url='https://github.com/elementary/switchboard-plug-pantheon-shell'
-license=('GPL3')
-groups=('pantheon-unstable')
-depends=('gdk-pixbuf2' 'glib2' 'glibc' 'gnome-desktop' 'gtk3' 'libgee'
- 'libgexiv2' 'plank'
- 'libgranite.so' 'libswitchboard-2.0.so')
-makedepends=('git' 'granite-git' 'libgexiv2' 'meson' 'switchboard-git' 'vala')
-provides=('switchboard-plug-desktop')
-conflicts=('switchboard-plug-desktop')
-source=('switchboard-plug-desktop::git+https://github.com/elementary/switchboard-plug-pantheon-shell.git'
- 'switchboard-plug-desktop-paths.patch')
-sha256sums=('SKIP'
- '75353594da255ecc16b277e65f7a2bdc1a0aef17e6ab30a0be7b8636d60379c5')
+arch=(x86_64)
+url=https://github.com/elementary/switchboard-plug-pantheon-shell
+license=(GPL3)
+groups=(pantheon-unstable)
+depends=(
+ gdk-pixbuf2
+ glib2
+ gnome-desktop
+ gtk3
+ libgee
+ libgexiv2
+ libgranite.so
+ libswitchboard-2.0.so
+ plank
+ tumbler
+)
+makedepends=(
+ git
+ granite-git
+ libgexiv2
+ meson
+ switchboard-git
+ vala
+)
+provides=(switchboard-plug-desktop)
+conflicts=(switchboard-plug-desktop)
+source=(switchboard-plug-desktop::git+https://github.com/elementary/switchboard-plug-pantheon-shell.git)
+sha256sums=(SKIP)
pkgver() {
cd switchboard-plug-desktop
@@ -26,27 +40,16 @@ pkgver() {
}
prepare() {
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
-
- cd switchboard-plug-desktop
-
- patch -Np1 -i ../switchboard-plug-desktop-paths.patch
+ sed 's|/usr/share/backgrounds|/usr/share/backgrounds/elementary|' -i switchboard-plug-desktop/src/Views/Wallpaper.vala
}
build() {
- cd build
-
- arch-meson ../switchboard-plug-desktop
- ninja
+ arch-meson switchboard-plug-desktop build
+ ninja -C build
}
package() {
- cd build
-
- DESTDIR="${pkgdir}" ninja install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et:
diff --git a/switchboard-plug-desktop-paths.patch b/switchboard-plug-desktop-paths.patch
deleted file mode 100644
index 67fd4ac369af..000000000000
--- a/switchboard-plug-desktop-paths.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rupN switchboard-plug-desktop.orig/src/Views/Wallpaper.vala switchboard-plug-desktop/src/Views/Wallpaper.vala
---- switchboard-plug-desktop.orig/src/Views/Wallpaper.vala 2016-12-20 14:13:11.207917562 +0100
-+++ switchboard-plug-desktop/src/Views/Wallpaper.vala 2016-12-20 14:13:47.472669721 +0100
-@@ -81,7 +81,7 @@ public class Wallpaper : Gtk.EventBox {
- // name of the default-wallpaper-link that we can prevent loading it again
- // (assumes that the defaultwallpaper is also in the system wallpaper directory)
- static string DEFAULT_LINK = "file://%s/elementaryos-default".printf (SYSTEM_BACKGROUNDS_PATH);
-- const string SYSTEM_BACKGROUNDS_PATH = "/usr/share/backgrounds";
-+ const string SYSTEM_BACKGROUNDS_PATH = "/usr/share/backgrounds/pantheon";
-
- public Switchboard.Plug plug { get; construct set; }
- private GLib.Settings settings;