summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-01 22:35:36 +0200
committerMaxime Gauduin2017-05-01 22:35:36 +0200
commitcba381bebc0b379d4da3f7b773cfe2a8a25718a6 (patch)
tree2ec343877a34890a344dee708595d64b900f1a7b
downloadaur-cba381bebc0b379d4da3f7b773cfe2a8a25718a6.tar.gz
Add switchboard-plug-network-git
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD51
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0b6c68c1245
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Mon May 1 20:35:36 UTC 2017
+pkgbase = switchboard-plug-network-git
+ pkgdesc = Network plug for Switchboard
+ pkgver = r582.16f3beb
+ pkgrel = 1
+ url = https://github.com/elementary/switchboard-plug-networking
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = granite-git
+ makedepends = switchboard-git
+ makedepends = vala
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgee
+ depends = libnm-glib
+ depends = nm-connection-editor
+ depends = libgranite.so
+ depends = libswitchboard-2.0.so
+ provides = switchboard-plug-network
+ conflicts = switchboard-plug-network-bzr
+ source = switchboard-plug-network::git+https://github.com/elementary/switchboard-plug-networking.git
+ sha256sums = SKIP
+
+pkgname = switchboard-plug-network-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5db5a17c751e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=switchboard-plug-network-git
+pkgver=r582.16f3beb
+pkgrel=1
+pkgdesc='Network plug for Switchboard'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/switchboard-plug-networking'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('glib2' 'glibc' 'gtk3' 'libgee' 'libnm-glib' 'nm-connection-editor'
+ 'libgranite.so' 'libswitchboard-2.0.so')
+makedepends=('cmake' 'git' 'granite-git' 'switchboard-git' 'vala')
+provides=('switchboard-plug-network')
+conflicts=('switchboard-plug-network')
+conflicts=('switchboard-plug-network-bzr')
+source=('switchboard-plug-network::git+https://github.com/elementary/switchboard-plug-networking.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd switchboard-plug-network
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd switchboard-plug-network
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd switchboard-plug-network/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd switchboard-plug-network/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: