summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-08-17 21:25:02 -0400
committerSolomon Choina2020-08-17 21:25:02 -0400
commitb9ff3229c8ea7151f0e56e40de3020556953b419 (patch)
treec9dc16b0f308256942a5135d66084b1e4ee3f62f
parent4ec0688ff6396989d0461104ad10dc4816fd94d7 (diff)
downloadaur-b9ff3229c8ea7151f0e56e40de3020556953b419.tar.gz
normal switchboard, normal granite and updpkgver
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 9 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ccd53e71f19..aa374da33f35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Mar 29 18:40:13 UTC 2018
pkgbase = switchboard-plug-parental-controls-git
pkgdesc = Switchboard Parental Controls Plug
- pkgver = r409.9e72211
+ pkgver = 3.0.1.r21.g5d9f013
pkgrel = 1
url = https://github.com/elementary/switchboard-plug-parental-controls
arch = x86_64
groups = pantheon-unstable
license = GPL3
makedepends = git
- makedepends = granite-git
+ makedepends = granite
makedepends = meson
- makedepends = switchboard-git
+ makedepends = switchboard
makedepends = vala
depends = accountsservice
depends = gdk-pixbuf2
diff --git a/PKGBUILD b/PKGBUILD
index df5c9c2923a6..2d181733a6ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-plug-parental-controls-git
-pkgver=r409.9e72211
+pkgver=3.0.1.r21.g5d9f013
pkgrel=1
pkgdesc='Switchboard Parental Controls Plug'
arch=('x86_64')
@@ -11,7 +11,7 @@ groups=('pantheon-unstable')
depends=('accountsservice' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libgee'
'polkit'
'libgranite.so' 'libswitchboard-2.0.so')
-makedepends=('git' 'granite-git' 'meson' 'switchboard-git' 'vala')
+makedepends=('git' 'granite' 'meson' 'switchboard' 'vala')
provides=('switchboard-plug-parental-controls')
conflicts=('switchboard-plug-parental-controls')
source=('git+https://github.com/elementary/switchboard-plug-parental-controls.git')
@@ -20,27 +20,16 @@ sha256sums=('SKIP')
pkgver() {
cd switchboard-plug-parental-controls
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd build
-
- arch-meson ../switchboard-plug-parental-controls
- ninja
+ arch-meson switchboard-plug-parental-controls build
+ ninja -C build
}
package() {
- cd build
-
- DESTDIR="${pkgdir}" ninja install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et: