summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2022-07-02 23:05:28 +0300
committerMantas Mikulėnas2022-07-02 23:10:11 +0300
commite8538d9e38edb6e8a4d45e1df0eb1cd30aa7952b (patch)
tree60c375f7822a6ff09b3843eefefa8ca066e2c388
parent15b7700c7f8b772f9a15d12976e81a429b06f8c4 (diff)
downloadaur-e8538d9e38edb6e8a4d45e1df0eb1cd30aa7952b.tar.gz
release 2.6
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5da82d48326f..f0d22efd7bf6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = switcheroo-control
pkgdesc = D-Bus service to check the availability of dual-GPU
- pkgver = 2.5
- pkgrel = 3
+ pkgver = 2.6
+ pkgrel = 1
url = https://gitlab.freedesktop.org/hadess/switcheroo-control
arch = i686
arch = x86_64
@@ -13,13 +13,10 @@ pkgbase = switcheroo-control
makedepends = libxslt
makedepends = meson
makedepends = systemd
- makedepends = dbus-python
- makedepends = python-dbusmock
- makedepends = umockdev
depends = glib2
depends = libgudev
depends = python
- source = git+https://gitlab.freedesktop.org/hadess/switcheroo-control.git#commit=992977918026e4eec352d38728b2e55f73fd02d2
+ source = git+https://gitlab.freedesktop.org/hadess/switcheroo-control.git#commit=0dd257edd6b27589d2a1013cda1d2d5f325eee8b
sha256sums = SKIP
pkgname = switcheroo-control
diff --git a/PKGBUILD b/PKGBUILD
index 1ed4b87bb21d..082b86c22097 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
pkgname=switcheroo-control
-pkgver=2.5
-pkgrel=3
+# Note to self: Update _commit, not pkgver
+pkgver=2.6
+pkgrel=1
pkgdesc="D-Bus service to check the availability of dual-GPU"
arch=(i686 x86_64)
url="https://gitlab.freedesktop.org/hadess/switcheroo-control"
license=(GPL3)
depends=(glib2 libgudev python)
makedepends=(git libxslt meson systemd)
-# test dependencies need to be present for unittest_inspector at build time
-makedepends+=(dbus-python python-dbusmock umockdev)
checkdepends=(dbus-python python-dbusmock umockdev)
-_commit=992977918026e4eec352d38728b2e55f73fd02d2
+_commit=0dd257edd6b27589d2a1013cda1d2d5f325eee8b
source=("git+https://gitlab.freedesktop.org/hadess/switcheroo-control.git#commit=$_commit")
sha256sums=('SKIP')
@@ -21,6 +20,8 @@ pkgver() {
build() {
arch-meson $pkgname build
+ # TODO: Figure out when/how to add -Dtests=true. I think we'd need to check
+ # either for (( CHECKFUNC )) or `! check_buildenv check n`.
meson compile -C build
}