summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJanek2022-07-07 15:28:34 +0200
committerJanek2022-07-07 15:28:34 +0200
commit47e338ff1f755dc5cba7bc445540ec974ed9fdd8 (patch)
treeb11d3d45547ded9719c21774b3d09e8b28e1b30d
downloadaur-47e338ff1f755dc5cba7bc445540ec974ed9fdd8.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d921b83d9e13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = switcheroo-git
+ pkgdesc = A cross platform, rust implementation for the Tegra X1 bootROM exploit.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/budde25/switcheroo
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cargo
+ depends = glibc
+ provides = switcheroo
+ conflicts = switcheroo
+ source = git+https://github.com/budde25/switcheroo.git
+ sha256sums = SKIP
+
+pkgname = switcheroo-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc274ecdd026
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Janek S. <development@superyu.xyz>
+pkgname='switcheroo-git'
+_pkgname='switcheroo'
+pkgver='0.1.0'
+pkgrel=1
+pkgdesc='A cross platform, rust implementation for the Tegra X1 bootROM exploit.'
+url='https://github.com/budde25/switcheroo'
+source=('git+https://github.com/budde25/switcheroo.git')
+arch=('x86_64')
+license=('GPL2')
+makedepends=('git' 'cargo')
+depends=('glibc')
+conflicts=('switcheroo')
+provides=('switcheroo')
+sha256sums=(SKIP)
+
+build() {
+ cd $_pkgname
+ cargo build --release
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname/target/release/switcheroo" "$pkgdir/usr/bin/switcheroo"
+ install -Dm644 "$srcdir/$_pkgname/extra/linux/io.ebudd.Switcheroo.desktop" -t "$pkgdir/usr/share/applications/"
+} \ No newline at end of file