summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspecter1192022-04-05 20:25:13 +0800
committerspecter1192022-04-05 20:25:13 +0800
commit2c14e497bb74ef97f1632b7f193d5171fd42f70e (patch)
treedf268e8d78badba536e36499841cb0286d5be929
parentbc9eeb475b3c171a96fa0c5f5501a8c48a141e9d (diff)
downloadaur-2c14e497bb74ef97f1632b7f193d5171fd42f70e.tar.gz
v 4.1.1 with fix
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD71
-rw-r--r--switchhosts-bin.desktop8
-rw-r--r--switchhosts-bin.install11
5 files changed, 42 insertions, 78 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6739bfc57c2..f97138206f61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = switchhosts-bin
pkgdesc = Switch hosts quickly!
- pkgver = 3.5.4
- pkgrel = 5517
- url = https://oldj.github.io/SwitchHosts
+ pkgver = 4.1.1
+ pkgrel = 1
+ url = https://github.com/oldj/SwitchHosts
arch = x86_64
license = MIT
- makedepends = imagemagick
- depends = desktop-file-utils
+ depends = gtk3
+ depends = libnotify
+ depends = nss
+ depends = libxss
+ depends = libxtst
+ depends = xdg-utils
+ depends = at-spi2-core
+ depends = util-linux-libs
+ depends = libsecret
+ optdepends = libappindicator-gtk3
options = !strip
- source = https://github.com/oldj/SwitchHosts/releases/download/v3.5.4/SwitchHosts._linux_x64_3.5.4.5517.zip
- source = https://raw.githubusercontent.com/oldj/SwitchHosts/master/app/assets/logo@512w.png
- source = switchhosts-bin.install
- source = switchhosts-bin.desktop
- sha256sums = c18e055e62a4509cbcf7e3b053783e45278e5bc26deb764d9b0c4c24f0b84e88
- sha256sums = b5ade225a7428f195babb47e3cf4760467b0514cca18f477011b339a7af9b685
- sha256sums = 9fe12f1bc573f5d431fcc8f9ca3ed17fc1e1d30248ae3b58209fc53084ae0a4e
- sha256sums = 7b17a4bd74b5652dae1d92054ca153e64b51e7271bf7ded0488d1f0aa8e2782c
+ source = https://github.com/oldj/SwitchHosts/releases/download/v4.1.1/SwitchHosts_linux_amd64_4.1.1.6077.deb
+ sha256sums = 1793245d257818e0a29ab4ea1481af06f56fbbefc96981f9f3b2eb77755ffb67
pkgname = switchhosts-bin
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1365d6b09ff0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+SwitchHosts*.deb
diff --git a/PKGBUILD b/PKGBUILD
index 9455113371a1..14773a56a1ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,32 @@
-# Maintainer: Berturion <berturion@free.fr>
+# Maintainer: Specter119 <spcter119 AT gmail.com>
+# Contributor: Berturion@free.fr>
pkgname=switchhosts-bin
-pkgver=3.5.4
-pkgrel=5517
-pkgdesc="Switch hosts quickly!"
-arch=('x86_64')
-url="https://oldj.github.io/SwitchHosts"
-license=("MIT")
+pkgver=4.1.1
+pkgrel=1
+pkgdesc='Switch hosts quickly!'
+arch=(x86_64)
+url=https://github.com/oldj/SwitchHosts
+license=(MIT)
options=(!strip)
-depends=("desktop-file-utils")
-makedepends=("imagemagick")
-source=(
- 'https://github.com/oldj/SwitchHosts/releases/download/v3.5.4/SwitchHosts._linux_x64_3.5.4.5517.zip'
- 'https://raw.githubusercontent.com/oldj/SwitchHosts/master/app/assets/logo@512w.png'
- 'switchhosts-bin.install'
- 'switchhosts-bin.desktop'
-)
-sha256sums=(
- 'c18e055e62a4509cbcf7e3b053783e45278e5bc26deb764d9b0c4c24f0b84e88'
- 'b5ade225a7428f195babb47e3cf4760467b0514cca18f477011b339a7af9b685'
- '9fe12f1bc573f5d431fcc8f9ca3ed17fc1e1d30248ae3b58209fc53084ae0a4e'
- '7b17a4bd74b5652dae1d92054ca153e64b51e7271bf7ded0488d1f0aa8e2782c'
-)
-rm_src_files=(
- 'SwitchHosts._linux_x64_3.5.4.5517.zip'
- 'logo@512w.png'
+depends=(
+ gtk3
+ libnotify
+ nss
+ libxss
+ libxtst
+ xdg-utils
+ at-spi2-core
+ util-linux-libs
+ libsecret
)
+optdepends=(libappindicator-gtk3)
+source=($url/releases/download/v4.1.1/SwitchHosts_linux_amd64_4.1.1.6077.deb)
+sha256sums=('1793245d257818e0a29ab4ea1481af06f56fbbefc96981f9f3b2eb77755ffb67')
+
package() {
- install -dm755 "$pkgdir/"{opt,usr/bin}
- cp -r "${srcdir}" "${pkgdir}/opt/${pkgname}"
- # remove useless source files
- for rm_src_file in ${rm_src_files[*]} ; do
- rm "${pkgdir}/opt/${pkgname}/${rm_src_file}"
- done
- ln -s "/opt/${pkgname}/switchhosts" "$pkgdir/usr/bin/switchhosts"
- install -Dm644 ${srcdir}/${pkgname}.desktop "$pkgdir"/usr/share/applications/${pkgname}.desktop
- # icons generation
- mkdir -p "icons"
- cd "icons"
- mv ${srcdir}/logo@512w.png logo_icon.png
- convert -background transparent logo_icon.png -define icon:auto-resize=16,32,48,64,128,256 app.ico
- convert app.ico logo_icon.png
- # icons installation
- sizes=(16 32 48 64 128 256)
- for i in 0 1 2 3 4 ; do
- install -d "${pkgdir}/usr/share/icons/hicolor/${sizes[$i]}x${sizes[$i]}/apps"
- install -Dm644 "logo_icon-${i}.png" \
- "${pkgdir}/usr/share/icons/hicolor/${sizes[$i]}x${sizes[$i]}/apps/${pkgname}.png"
- done
+ bsdtar -xf $srcdir/data.tar.xz -C $pkgdir
+ mkdir -p $pkgdir/usr/share/pixmaps/
+ mv $pkgdir/usr/share/{icons/hicolor/0x0/apps,pixmaps}/switchhosts.png
+ rm -rf $pkgdir/usr/share/icons
}
diff --git a/switchhosts-bin.desktop b/switchhosts-bin.desktop
deleted file mode 100644
index 4fb4c2dba664..000000000000
--- a/switchhosts-bin.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Name=SwitchHosts
-Comment=Switch hosts quickly!
-Exec=switchhosts
-Icon=switchhosts-bin
-Terminal=false
-Type=Application
-Categories=Development;
diff --git a/switchhosts-bin.install b/switchhosts-bin.install
deleted file mode 100644
index e111ef946053..000000000000
--- a/switchhosts-bin.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}