summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspecter1192022-04-05 20:57:24 +0800
committerspecter1192022-04-05 20:57:24 +0800
commitb338421db9e72b0a97ad48acfc531d83d9089b5b (patch)
tree83113c7cc6732fe2fed81f80ccbab0e8c0a5d9bc
parent2c14e497bb74ef97f1632b7f193d5171fd42f70e (diff)
downloadaur-b338421db9e72b0a97ad48acfc531d83d9089b5b.tar.gz
add lic, symlink for binary
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD18
3 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f97138206f61..4504762b777f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = switchhosts-bin
pkgdesc = Switch hosts quickly!
pkgver = 4.1.1
- pkgrel = 1
- url = https://github.com/oldj/SwitchHosts
+ pkgrel = 2
+ url = https://swh.app/
arch = x86_64
- license = MIT
+ license = APACHE
depends = gtk3
depends = libnotify
depends = nss
@@ -17,6 +17,8 @@ pkgbase = switchhosts-bin
optdepends = libappindicator-gtk3
options = !strip
source = https://github.com/oldj/SwitchHosts/releases/download/v4.1.1/SwitchHosts_linux_amd64_4.1.1.6077.deb
+ source = https://raw.githubusercontent.com/oldj/SwitchHosts/master/LICENSE
sha256sums = 1793245d257818e0a29ab4ea1481af06f56fbbefc96981f9f3b2eb77755ffb67
+ sha256sums = c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4
pkgname = switchhosts-bin
diff --git a/.gitignore b/.gitignore
index 1365d6b09ff0..85a54e28cad2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
-SwitchHosts*.deb
+/LICENSE
+/SwitchHosts*.deb
diff --git a/PKGBUILD b/PKGBUILD
index 14773a56a1ac..a8b2944aa3ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
pkgname=switchhosts-bin
pkgver=4.1.1
-pkgrel=1
+pkgrel=2
pkgdesc='Switch hosts quickly!'
arch=(x86_64)
-url=https://github.com/oldj/SwitchHosts
-license=(MIT)
+url=https://swh.app/
+license=(APACHE)
options=(!strip)
depends=(
gtk3
@@ -21,12 +21,16 @@ depends=(
libsecret
)
optdepends=(libappindicator-gtk3)
-source=($url/releases/download/v4.1.1/SwitchHosts_linux_amd64_4.1.1.6077.deb)
-sha256sums=('1793245d257818e0a29ab4ea1481af06f56fbbefc96981f9f3b2eb77755ffb67')
+source=(https://github.com/oldj/SwitchHosts/releases/download/v4.1.1/SwitchHosts_linux_amd64_4.1.1.6077.deb
+ https://raw.githubusercontent.com/oldj/SwitchHosts/master/LICENSE)
+sha256sums=('1793245d257818e0a29ab4ea1481af06f56fbbefc96981f9f3b2eb77755ffb67'
+ 'c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4')
package() {
bsdtar -xf $srcdir/data.tar.xz -C $pkgdir
- mkdir -p $pkgdir/usr/share/pixmaps/
+ mkdir -p $pkgdir/usr/{bin,share/pixmaps}/
mv $pkgdir/usr/share/{icons/hicolor/0x0/apps,pixmaps}/switchhosts.png
- rm -rf $pkgdir/usr/share/icons
+ rm -rf $pkgdir/usr/share/{doc,icons}
+ ln -s /opt/SwitchHosts/switchhosts $pkgdir/usr/bin/
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
}