summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBerturion2020-04-26 09:09:39 +0400
committerBerturion2020-04-26 09:09:39 +0400
commitbc9eeb475b3c171a96fa0c5f5501a8c48a141e9d (patch)
treee1e1ae93116da4275c7711daeafe240ca4427661
parent35892cc75709213f1b67bea56409e7c036f0b985 (diff)
downloadaur-bc9eeb475b3c171a96fa0c5f5501a8c48a141e9d.tar.gz
packaging optimizations
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 26 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a31b8312da9a..b6739bfc57c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,28 +3,19 @@ pkgbase = switchhosts-bin
pkgver = 3.5.4
pkgrel = 5517
url = https://oldj.github.io/SwitchHosts
- arch = any
+ arch = x86_64
license = MIT
makedepends = imagemagick
- makedepends = npm
- depends = gconf
- depends = gtk2
- depends = libnotify
- depends = libxtst
- depends = nss
- depends = python2
- depends = xdg-utils
depends = desktop-file-utils
- depends = alsa-lib
options = !strip
source = https://github.com/oldj/SwitchHosts/releases/download/v3.5.4/SwitchHosts._linux_x64_3.5.4.5517.zip
source = https://raw.githubusercontent.com/oldj/SwitchHosts/master/app/assets/logo@512w.png
source = switchhosts-bin.install
source = switchhosts-bin.desktop
- md5sums = bd23ba93ba19ed1377e0bd36f6f9376b
- md5sums = 06eb97a4b5b5ddf7a06841e01d5562eb
- md5sums = 0b6211b511da48346cecdc1d2f963c76
- md5sums = c6594fabba5e7f9d5ae0736524f6f634
+ sha256sums = c18e055e62a4509cbcf7e3b053783e45278e5bc26deb764d9b0c4c24f0b84e88
+ sha256sums = b5ade225a7428f195babb47e3cf4760467b0514cca18f477011b339a7af9b685
+ sha256sums = 9fe12f1bc573f5d431fcc8f9ca3ed17fc1e1d30248ae3b58209fc53084ae0a4e
+ sha256sums = 7b17a4bd74b5652dae1d92054ca153e64b51e7271bf7ded0488d1f0aa8e2782c
pkgname = switchhosts-bin
diff --git a/PKGBUILD b/PKGBUILD
index a0bb93e3d80a..9455113371a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,35 @@ pkgname=switchhosts-bin
pkgver=3.5.4
pkgrel=5517
pkgdesc="Switch hosts quickly!"
-arch=('any')
+arch=('x86_64')
url="https://oldj.github.io/SwitchHosts"
license=("MIT")
options=(!strip)
-depends=("gconf" "gtk2" "libnotify" "libxtst" "nss" "python2" "xdg-utils" "desktop-file-utils" "alsa-lib")
-makedepends=("imagemagick" "npm")
-
+depends=("desktop-file-utils")
+makedepends=("imagemagick")
source=(
- "https://github.com/oldj/SwitchHosts/releases/download/v${pkgver}/SwitchHosts._linux_x64_${pkgver}.${pkgrel}.zip"
- "https://raw.githubusercontent.com/oldj/SwitchHosts/master/app/assets/logo@512w.png"
- "${pkgname}.install"
- "${pkgname}.desktop"
+ 'https://github.com/oldj/SwitchHosts/releases/download/v3.5.4/SwitchHosts._linux_x64_3.5.4.5517.zip'
+ 'https://raw.githubusercontent.com/oldj/SwitchHosts/master/app/assets/logo@512w.png'
+ 'switchhosts-bin.install'
+ 'switchhosts-bin.desktop'
+)
+sha256sums=(
+ 'c18e055e62a4509cbcf7e3b053783e45278e5bc26deb764d9b0c4c24f0b84e88'
+ 'b5ade225a7428f195babb47e3cf4760467b0514cca18f477011b339a7af9b685'
+ '9fe12f1bc573f5d431fcc8f9ca3ed17fc1e1d30248ae3b58209fc53084ae0a4e'
+ '7b17a4bd74b5652dae1d92054ca153e64b51e7271bf7ded0488d1f0aa8e2782c'
+)
+rm_src_files=(
+ 'SwitchHosts._linux_x64_3.5.4.5517.zip'
+ 'logo@512w.png'
)
-
-md5sums=('bd23ba93ba19ed1377e0bd36f6f9376b'
- '06eb97a4b5b5ddf7a06841e01d5562eb'
- '0b6211b511da48346cecdc1d2f963c76'
- 'c6594fabba5e7f9d5ae0736524f6f634')
-
package() {
install -dm755 "$pkgdir/"{opt,usr/bin}
cp -r "${srcdir}" "${pkgdir}/opt/${pkgname}"
+ # remove useless source files
+ for rm_src_file in ${rm_src_files[*]} ; do
+ rm "${pkgdir}/opt/${pkgname}/${rm_src_file}"
+ done
ln -s "/opt/${pkgname}/switchhosts" "$pkgdir/usr/bin/switchhosts"
install -Dm644 ${srcdir}/${pkgname}.desktop "$pkgdir"/usr/share/applications/${pkgname}.desktop
# icons generation