summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Boughton2018-09-19 13:20:07 +0100
committerNick Boughton2018-09-19 13:20:07 +0100
commit1f173b49af8a34cf35d425f83e5f7c6570261522 (patch)
treec505630bbade95b102755e80361e4710c6616adf
downloadaur-1f173b49af8a34cf35d425f83e5f7c6570261522.tar.gz
initial package build for v0.7.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..070eddeed3e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = swnt
+ pkgdesc = Command line GM tools for Stars Without Number
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = https://github.com/nboughton/swnt
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = git
+ optdepends = hugo: export sectors as hugo sites
+ source = swnt-0.7.2.tar.gz::https://github.com/nboughton/swnt/archive/v0.7.2.tar.gz
+ sha1sums = f88eaa46d96b23986453c8bda0d7d77fab22e167
+
+pkgname = swnt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d86927d0030f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: N.Boughton, <nicholasboughton@gmail.com>
+pkgname=swnt
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="Command line GM tools for Stars Without Number"
+arch=('x86_64')
+url="https://github.com/nboughton/swnt"
+license=("MIT")
+depends=("git")
+makedepends=('go')
+optdepends=('hugo: export sectors as hugo sites')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/nboughton/swnt/archive/v${pkgver}.tar.gz")
+sha1sums=('f88eaa46d96b23986453c8bda0d7d77fab22e167')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ go build -v -o swnt
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}