summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Pigott2020-06-30 14:35:36 -0700
committerRonan Pigott2020-06-30 14:35:36 -0700
commit7515b947ca370c3a128e5d85a33f2970a0a47441 (patch)
tree578339077fb7fe4aff0101d28fa9b375368b4fca
downloadaur-7515b947ca370c3a128e5d85a33f2970a0a47441.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--40-swop.conf1
-rw-r--r--PKGBUILD30
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2828fad3f38b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = swop
+ pkgdesc = i3 open but for Wayland
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://git.sr.ht/~brocellous/swop
+ arch = x86_64
+ license = MIT
+ depends = wayland
+ source = swop-0.1.tar.gz::https://git.sr.ht/~brocellous/swop/archive/v0.1.tar.gz
+ source = 40-swop.conf
+ md5sums = ef0d2578ef02b690cb70c89e71c501e8
+ md5sums = SKIP
+
+pkgname = swop
+
diff --git a/40-swop.conf b/40-swop.conf
new file mode 100644
index 000000000000..a7d10cafdb09
--- /dev/null
+++ b/40-swop.conf
@@ -0,0 +1 @@
+for_window [app_id="^swop$"] border none
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35adc2fe059a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Ronan Pigott <rpigott@berkeley.edu>
+
+pkgname=swop
+pkgver=0.1
+pkgrel=1
+pkgdesc='i3 open but for Wayland'
+url='https://git.sr.ht/~brocellous/swop'
+arch=('x86_64')
+license=('MIT')
+source=(
+ "$pkgname-$pkgver.tar.gz::https://git.sr.ht/~brocellous/$pkgname/archive/v$pkgver.tar.gz"
+ "40-swop.conf"
+)
+depends=('wayland')
+md5sums=(
+ 'ef0d2578ef02b690cb70c89e71c501e8'
+ 'SKIP'
+)
+
+build() {
+ cd "$pkgname-v$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-v$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+ install -Dm644 "$srcdir/40-swop.conf" "$pkgdir/etc/sway/config.d/40-swop.conf"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}