summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Nehls2016-01-07 16:48:18 +0100
committerRobin Nehls2016-01-07 16:49:43 +0100
commit32cefe3c8b297f836373af94719c771ef0146a00 (patch)
tree79599da5674612b8d62bd5ed81e2700f961dccf0
downloadaur-32cefe3c8b297f836373af94719c771ef0146a00.tar.gz
initial
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD34
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85993a940156
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+# Generated by mksrcinfo v8
+# Thu Jan 7 15:49:32 UTC 2016
+pkgbase = swtpm-git
+ pkgdesc = Libtpms-based TPM emulator with socket, character device, and Linux CUSE interface.
+ pkgver = c9de5f0
+ pkgrel = 1
+ url = https://github.com/stefanberger/swtpm
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = bash
+ makedepends = coreutils
+ makedepends = expect
+ makedepends = sed
+ depends = openssl
+ depends = zlib
+ depends = libtpms
+ depends = tpm-tools
+ depends = pcre
+ depends = libtasn1
+ depends = gnutls
+ depends = p11-kit
+ depends = nettle
+ depends = libffi
+ depends = fuse
+ depends = glib2
+ provides = swtpm
+ source = git+https://github.com/stefanberger/swtpm.git
+ sha1sums = SKIP
+
+pkgname = swtpm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdcf89f4049c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Robin Nehls <aur@manol.is>
+
+pkgname=swtpm-git
+pkgver=c9de5f0
+pkgrel=1
+pkgdesc="Libtpms-based TPM emulator with socket, character device, and Linux CUSE interface."
+arch=('i686' 'x86_64')
+url="https://github.com/stefanberger/swtpm"
+license=('BSD')
+depends=('openssl' 'zlib' 'libtpms' 'tpm-tools' 'pcre' 'libtasn1' 'gnutls' 'p11-kit' 'nettle' 'libffi' 'fuse' 'glib2')
+makedepends=('automake' 'autoconf' 'bash' 'coreutils' 'expect' 'sed')
+provides=('swtpm')
+source=('git+https://github.com/stefanberger/swtpm.git')
+sha1sums=('SKIP')
+_gitname=swtpm
+
+pkgver() {
+ cd $_gitname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd $_gitname
+ ./bootstrap.sh
+ ./configure --prefix=/usr --with-openssl
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: