summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2021-05-28 22:05:42 +0200
committerJonas Witschel2021-05-28 22:05:42 +0200
commitf7e4d5eec1880334c3983018c6401036b32bab5b (patch)
tree1bca575ce587e6f6f47a330907fb865bcc13e11d
parent09977bd066b5c289d29cec77853e03c96a447086 (diff)
downloadaur-f7e4d5eec1880334c3983018c6401036b32bab5b.tar.gz
upgpkg: swtpm-git 0.5.0.r63.c125e34-1: swtpm_setup rewritten in C
- Upstream commit https://github.com/stefanberger/swtpm/commit/c125e34bf23afa8e0f0b876c352310b7b46ae826 rewrote swtpm_setup in C, adjust the build process and dependencies accordingly. - Change the permissions of the /var/lib/swtpm-localca directory as in the stable swtpm repository package to avoid pacman warnings during upgrades.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e12c8a158039..05d57e602f8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = swtpm-git
pkgdesc = Libtpms-based TPM emulator with socket, character device, and Linux CUSE interface
- pkgver = 0.5.0.r31.526c9fa
+ pkgver = 0.5.0.r63.c125e34
pkgrel = 1
url = https://github.com/stefanberger/swtpm
arch = x86_64
@@ -8,23 +8,23 @@ pkgbase = swtpm-git
checkdepends = softhsm
makedepends = git
makedepends = expect
- makedepends = gnutls
makedepends = iproute2
makedepends = libtasn1
makedepends = python
- makedepends = python-cryptography
makedepends = python-setuptools
makedepends = socat
depends = fuse2
depends = glib2
+ depends = gnutls
+ depends = json-glib
depends = libseccomp
depends = libtpms
depends = libseccomp.so
- optdepends = gnutls: swtpm_cert support
- optdepends = python-cryptography: swtpm_setup support
+ optdepends = python: swtpm-localca support
provides = swtpm
conflicts = swtpm
source = git+https://github.com/stefanberger/swtpm.git
sha512sums = SKIP
pkgname = swtpm-git
+
diff --git a/PKGBUILD b/PKGBUILD
index 6a3838d4149d..1c8c19f5d16f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Jonas Witschel <diabonas@archlinux.org>
pkgname=swtpm-git
-pkgver=0.5.0.r31.526c9fa
+pkgver=0.5.0.r63.c125e34
pkgrel=1
pkgdesc='Libtpms-based TPM emulator with socket, character device, and Linux CUSE interface'
arch=('x86_64')
url='https://github.com/stefanberger/swtpm'
license=('BSD')
-depends=('fuse2' 'glib2' 'libseccomp' 'libtpms' 'libseccomp.so')
-makedepends=('git' 'expect' 'gnutls' 'iproute2' 'libtasn1' 'python' 'python-cryptography' 'python-setuptools' 'socat')
+depends=('fuse2' 'glib2' 'gnutls' 'json-glib' 'libseccomp' 'libtpms' 'libseccomp.so')
+makedepends=('git' 'expect' 'iproute2' 'libtasn1' 'python' 'python-setuptools' 'socat')
checkdepends=('softhsm')
-optdepends=('gnutls: swtpm_cert support'
- 'python-cryptography: swtpm_setup support')
+optdepends=('python: swtpm-localca support')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+$url.git")
@@ -26,8 +25,7 @@ prepare() {
# Remove usage of /usr/bin/env to avoid PATH manipulation attacks
sed --in-place 's/env //' samples/swtpm-create-tpmca samples/swtpm-create-user-config-files.in \
- samples/swtpm-localca.in src/swtpm_setup/py_swtpm_setup/swtpm_setup.py \
- src/swtpm_setup/swtpm_setup.in
+ samples/swtpm-localca.in
autoreconf --install --force
}
@@ -37,7 +35,8 @@ build() {
./configure --prefix=/usr --with-cuse --with-gnutls --with-seccomp --disable-python-installation
make
- for _dir in samples src/swtpm_setup; do (cd "$_dir"; python setup.py build); done
+ cd samples
+ python setup.py build
}
check() {
@@ -50,11 +49,10 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
- for _dir in samples src/swtpm_setup
- do
- (cd "$_dir"; python setup.py install --root="$pkgdir" --optimize=1 --skip-build)
- done
+ cd samples
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
echo 'u tss - "tss user for tpm2"' | install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
echo 'z /var/lib/swtpm-localca 0750 tss root' | install -Dm644 /dev/stdin "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
+ chmod 750 "$pkgdir/var/lib/swtpm-localca"
}