summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Angelopoulos2016-02-03 23:45:26 +0100
committerGeorge Angelopoulos2016-02-03 23:45:26 +0100
commitb3af62436be9f2b8a0a1170266aaa03d3cd99b2a (patch)
tree2feda0d9da830ad0b4ac057e0c20b3412c9792a3
downloadaur-b3af62436be9f2b8a0a1170266aaa03d3cd99b2a.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be310645afcb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Wed Feb 3 22:45:13 UTC 2016
+pkgbase = sx
+ pkgdesc = sxconsole is a tool used to extract various report types and then analyze those extracted reports with plugins
+ pkgver = 2.17
+ pkgrel = 1
+ url = https://fedorahosted.org/sx/
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2
+
+pkgname = sx
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c1f6cf7f1528
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b870804d7fdd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# This PKGBUILD is for the latest stable version fo sx.
+# We use git to get the source code but then checkout to the
+# latest version tag. This is because no direct downloads (e.g.
+# tarballs) are provided.
+
+# Maintainer: George Angelopoulos <george@usermod.net>
+pkgname=sx
+pkgver="2.17"
+pkgrel=1
+pkgdesc="sxconsole is a tool used to extract various report types and then analyze those extracted reports with plugins"
+arch=('any')
+url="https://fedorahosted.org/sx/"
+license=('GPL')
+depends=('python2')
+makedepends=('git')
+
+_gitroot="git://git.fedorahosted.org/git/sx.git"
+_gitname="sx"
+_gitvertag="sx-${pkgver}"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+ git checkout "$_gitvertag"
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ python2 setup.py install --optimize 1 --root="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: