summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Minnocci2020-09-12 16:48:00 +0200
committerFrancesco Minnocci2020-09-12 16:48:00 +0200
commit292cb4539f6ceaee7ddd099f6dc13e00c78a939e (patch)
treedce6506fcf0145a7917db3bdba4b6efd72c927ac
downloadaur-292cb4539f6ceaee7ddd099f6dc13e00c78a939e.tar.gz
Initial package commit with custom bindings
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..121ba73550bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sxiv-bachoseven-git
+ pkgdesc = Simple (or small or suckless) X Image Viewer
+ pkgver = 2020.09.12
+ pkgrel = 1
+ url = https://github.com/BachoSeven/sxiv
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = imlib2
+ depends = libexif
+ depends = libxft
+ depends = hicolor-icon-theme
+ provides = sxiv
+ conflicts = sxiv
+ source = sxiv::git+https://github.com/BachoSeven/sxiv.git
+ sha256sums = SKIP
+
+pkgname = sxiv-bachoseven-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b1041df354d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Francesco Minnocci <ascoli dot minnocci at gmail dot com>
+# Contributor: Jason Ryan <jasonwryan@gmail.com>
+# Contributor: Steven Allen <steven@stebalien.com>
+# Contributor: Army
+# Contributor: Bastien Dejean <baskerville@lavabit.com>
+
+_name=sxiv
+pkgname="${_name}-bachoseven-git"
+pkgver=2020.09.12
+pkgrel=1
+pkgdesc="Simple (or small or suckless) X Image Viewer"
+arch=('i686' 'x86_64')
+url="https://github.com/BachoSeven/${_name}"
+license=('GPL2')
+depends=('imlib2' 'libexif' 'libxft' 'hicolor-icon-theme')
+makedepends=('git')
+provides=("${_name}")
+conflicts=("${_name}")
+source=("${_name}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ git log -1 --format="%cd" --date=short | sed 's/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${_name}"
+ # use your customisations if present
+ [[ -f $SRCDEST/config.h ]] && cp "$SRCDEST"/config.h .
+
+ # Allow custom FLAGS
+ sed -i Makefile -e 's|^CFLAGS\s*=|CFLAGS +=|' -e 's|^LDFLAGS\s*=|LDFLAGS +=|'
+}
+
+build() {
+ cd "$srcdir/${_name}"
+ export CFLAGS="$CFLAGS $CPPFLAGS"
+ make PREFIX="/usr"
+}
+
+package() {
+ cd "$srcdir/${_name}"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+ make -C icon PREFIX="/usr" DESTDIR="$pkgdir" install
+ install -Dm644 sxiv.desktop "$pkgdir/usr/share/applications/${_name}.desktop"
+}
+
+# vim:set ts=2 sw=2 et: