summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilip Parag2021-02-12 14:47:26 +0100
committerFilip Parag2021-02-12 14:47:26 +0100
commitb446ec3692de469868de2fa27525db9b544ee14b (patch)
tree461360a850e68f5188b8db20c50555b77aa6a141
parent4594b44ab40667e734fc8c59ede5d2e77df8b081 (diff)
downloadaur-b446ec3692de469868de2fa27525db9b544ee14b.tar.gz
revamp PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD55
2 files changed, 22 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98041c932a93..5494f50b872a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = sydf
- pkgdesc = Symlink Your Damn Files
+ pkgdesc = Symlink dotfiles
pkgver = 0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/filiparag/sydf
arch = any
- license = GPL
- source = https://github.com/filiparag/sydf
- md5sums = SKIP
+ license = GPL3
+ depends = bash
+ depends = coreutils
+ depends = findutils
+ source = sydf-0.3.tar.gz::https://github.com/filiparag/sydf/archive/0.3.tar.gz
+ sha256sums = d22297a611e19ba754a26f7f347316b904ba0a93c8957ad2adb916d12b90df55
pkgname = sydf
diff --git a/PKGBUILD b/PKGBUILD
index cd8d7f3b6c44..cfe7dcc34809 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,19 @@
-# Maintainer: Filip Parag <aur@filiparag.com>
+# Maintainer Filip Parag <aur@filiparag.com>
+
pkgname=sydf
pkgver=0.3
-pkgrel=1
-epoch=
-pkgdesc="Symlink Your Damn Files"
-arch=(any)
+pkgrel=2
+pkgdesc="Symlink dotfiles"
+arch=('any')
url="https://github.com/filiparag/sydf"
-license=('GPL')
-groups=()
-depends=()
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("https://github.com/filiparag/sydf")
-noextract=()
-md5sums=('SKIP')
-validpgpkeys=()
-
-prepare() {
- git clone -b "$pkgver" --depth 1 "$source" "$pkgname-git"
-}
-
-pkgver() {
- echo "$pkgver"
-}
-
-build() {
- chmod +x "$pkgname-git/sydf"
-}
-
-check() {
- test -f "$pkgname-git/sydf"
-}
+license=('GPL3')
+depends=('bash' 'coreutils' 'findutils')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('d22297a611e19ba754a26f7f347316b904ba0a93c8957ad2adb916d12b90df55')
package() {
- mkdir -p ${pkgdir}/usr/bin
- cp "$pkgname-git/sydf" ${pkgdir}/usr/bin
-}
+ cd "${pkgname}-${pkgver}"
+ install -Dm 755 -t "${pkgdir}/usr/bin/" "${pkgname}"
+ install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
+ install -Dm 644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
+} \ No newline at end of file