summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsygnmdev2017-09-01 00:27:41 +0200
committersygnmdev2017-09-01 00:27:41 +0200
commit37f7668930f358173452a1584f3edd17c156fbbe (patch)
tree16dd14e4287769454123ea8c46519af28b890d29
parentdcc59222599ada461c6de5c0e5d60ec3770b69e7 (diff)
downloadaur-37f7668930f358173452a1584f3edd17c156fbbe.tar.gz
Updated description, use git tag instead of .tar.gz file
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d4e05ec4b97..55ebececf5a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = sygnm
- pkgdesc = Computer algebra system (currently alpha, install only if you know what you are doing)
+ pkgdesc = Computer algebra framework (currently alpha, install only if you know what you are doing)
pkgver = 1.0.0alpha1
pkgrel = 2
url = https://sygnm.org/
diff --git a/PKGBUILD b/PKGBUILD
index d70e992b58fb..04b79c0c6f39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
pkgname=sygnm
pkgver=1.0.0alpha1
pkgrel=2
-pkgdesc="Computer algebra system (currently alpha, install only if you know what you are doing)"
+pkgdesc="Computer algebra framework (currently alpha, install only if you know what you are doing)"
arch=('i686' 'x86_64')
url="https://sygnm.org/"
license=('AGPL3')
depends=('flint' 'arb' 'boost-libs' 'icu' 'gmp' 'qt5-base' 'readline' 'python' 'sqlite')
makedepends=('boost' 'cmake' 'swig' 'python' 'python-setuptools')
-source=("local://$pkgname-$pkgver.tar.gz")
+source=("sygnm-git::git+https://git.sygnm.org/sygnmdev/sygnm.git#tag=1.0.0alpha1")
options=(debug !strip)
conflicts=('sygnm-git')
md5sums=('SKIP')
build() {
- cd "${srcdir}/$pkgname-$pkgver"
+ cd "${srcdir}/sygnm-git"
cmake . -DCMAKE_BUILD_TYPE=Debug -DSYGNM_BUILD_ALL=On -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd "${srcdir}/$pkgname-$pkgver"
+ cd "${srcdir}/sygnm-git"
make DESTDIR="$pkgdir/" install
cd sygnm-jupyter
python setup.py install --root="$pkgdir/" --optimize=1