summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOirio Joshi2018-12-16 15:57:15 +0100
committerOirio Joshi2018-12-16 15:57:15 +0100
commit532ce63e1df1a97456ece560e91eab61b0f50a28 (patch)
treecada1357b959d1d1c3d757f7bf94d74778c48940
parentd7a0242dd8ec320833f29bb117f828b948070912 (diff)
downloadaur-532ce63e1df1a97456ece560e91eab61b0f50a28.tar.gz
v2.4
-rw-r--r--.SRCINFO8
-rw-r--r--[-rwxr-xr-x]PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dbd5ec2fe38..a4349343e6f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = symphytum
pkgdesc = Personal database software
- pkgver = 2.3
+ pkgver = 2.4
pkgrel = 1
- url = http://giowck.github.io/symphytum/
+ url = https://github.com/giowck/symphytum
arch = i686
arch = x86_64
license = BSD
@@ -19,8 +19,8 @@ pkgbase = symphytum
depends = python-requests
depends = python-urllib3
optdepends = megacmd-bin: MEGA cloud sync support
- source = https://github.com/giowck/symphytum/releases/download/v2.3/symphytum-2.3-src.tar.gz
- md5sums = 587df53fc29f8fb86ce918c2b08d29dc
+ source = https://github.com/giowck/symphytum/releases/download/v2.4/symphytum-2.4-src.tar.gz
+ sha256sums = caa554aa83ed1d0ae19c552bb2bf2192b2e90073449e53ee4900cbeb1f63ee32
pkgname = symphytum
diff --git a/PKGBUILD b/PKGBUILD
index 71ec1d7d5e6c..7c0513d999e8 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Past Maintainer: Giorgio Wicklein <giowckln@gmail.com>
# Maintainer: Oirio Joshi <joshirio@protonmail.com>
pkgname=symphytum
-pkgver=2.3
+pkgver=2.4
pkgrel=1
pkgdesc="Personal database software"
arch=('i686' 'x86_64')
-url="http://giowck.github.io/symphytum/"
+url="https://github.com/giowck/symphytum"
license=('BSD')
depends=('qt5-base' 'qt5-svg' 'qt5-imageformats' 'sqlite' 'python3' 'python-setuptools' 'python-six' 'python-certifi' 'python-chardet' 'python-idna' 'python-requests' 'python-urllib3')
optdepends=('megacmd-bin: MEGA cloud sync support')
source=("https://github.com/giowck/symphytum/releases/download/v$pkgver/$pkgname-$pkgver-src.tar.gz")
-md5sums=('587df53fc29f8fb86ce918c2b08d29dc')
+sha256sums=('caa554aa83ed1d0ae19c552bb2bf2192b2e90073449e53ee4900cbeb1f63ee32')
build() {
qmake-qt5 -config release
@@ -30,9 +30,10 @@ package() {
# Sync framework files
install -d "${pkgdir}/usr/share/symphytum/"
+ tar xzvf $srcdir/stuff/installers/deb/usr/share/symphytum/sync/dropbox-*.tar.gz -C $srcdir/stuff/installers/deb/usr/share/symphytum/sync/
+ rm -v $srcdir/stuff/installers/deb/usr/share/symphytum/sync/dropbox-*.tar.gz
cp -R "$srcdir/stuff/installers/deb/usr/share/symphytum/" "${pkgdir}/usr/share/"
# Copy license
install -Dm644 "$srcdir/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-