summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiorgio Wicklein2015-06-08 21:22:10 +0200
committerGiorgio Wicklein2015-06-08 21:22:10 +0200
commita21cca78e8fb76dc28789b38c86a66a9999f54d3 (patch)
treee1df40c17d0693a6c592be86d2c78426a895f1cd
downloadaur-a21cca78e8fb76dc28789b38c86a66a9999f54d3.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13661a4e77cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = symphytum
+ pkgdesc = Personal database software
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://giowck.github.io/symphytum/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = qt4
+ depends = sqlite
+ depends = python2
+ depends = python2-setuptools
+ source = http://giowck.github.io/symphytum/files/symphytum-1.2-src.tar.gz
+ source = http://giowck.github.io/symphytum/files/symphytum-1.2-src.tar.gz.asc
+ md5sums = e35e8c1eee7f3343ed8007974272efda
+ md5sums = SKIP
+
+pkgname = symphytum
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3535c54f09e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Giorgio Wicklein <giowckln@gmail.com>
+pkgname=symphytum
+pkgver=1.2
+pkgrel=1
+pkgdesc="Personal database software"
+arch=('i686' 'x86_64')
+url="http://giowck.github.io/symphytum/"
+license=('BSD')
+depends=('qt4' 'sqlite' 'python2' 'python2-setuptools')
+source=("http://giowck.github.io/symphytum/files/$pkgname-$pkgver-src.tar.gz"
+ "http://giowck.github.io/symphytum/files/$pkgname-$pkgver-src.tar.gz.asc")
+md5sums=('e35e8c1eee7f3343ed8007974272efda'
+ 'SKIP')
+
+build() {
+ qmake-qt4 -config release
+ make
+}
+
+package() {
+ cd "$srcdir"
+
+ # Binary
+ install -Dm755 "$srcdir/symphytum" "${pkgdir}/usr/bin/symphytum"
+
+ # Icons and desktop files
+ install -d "${pkgdir}/usr/share/"
+ cp -R "$srcdir/stuff/installers/deb/usr/share/applications/" "${pkgdir}/usr/share/"
+ cp -R "$srcdir/stuff/installers/deb/usr/share/pixmaps/" "${pkgdir}/usr/share/"
+
+ # Sync framework files
+ install -d "${pkgdir}/usr/share/symphytum/"
+ cp -R "$srcdir/stuff/installers/deb/usr/share/symphytum/" "${pkgdir}/usr/share/"
+
+ # Copy license
+ install -Dm644 "$srcdir/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}