summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAuric Vente2022-07-05 04:54:24 -0600
committerAuric Vente2022-07-05 04:54:24 -0600
commit1db53344092d9be5ffa5f1da87dd22b0a583c516 (patch)
treeaa6e7d1a16e949dda16d76276d89f744fbf7db6b
downloadaur-1db53344092d9be5ffa5f1da87dd22b0a583c516.tar.gz
Mods
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD22
-rwxr-xr-xpush.sh5
4 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53f5c059bc47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = symview-git
+ pkgdesc = Find files and create symlinks
+ pkgver = r31.761d26e
+ pkgrel = 1
+ url = https://github.com/madprops/symview
+ arch = x86_64
+ license = GPL3
+ source = symview-git::git+https://github.com/madprops/symview.git
+ sha256sums = SKIP
+
+pkgname = symview-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d496fc20db06
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.SRCINFO
+!PKGBUILD
+!push.sh
+!.gitignore \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa8c91c90cb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: madprops <mprops at protonmail dot com>
+
+pkgname="symview-git"
+pkgdesc="Find files and create symlinks"
+pkgver=r31.761d26e
+pkgrel=1
+arch=("x86_64")
+url="https://github.com/madprops/symview"
+license=("GPL3")
+depends=()
+sha256sums=("SKIP")
+source=("$pkgname::git+https://github.com/madprops/symview.git")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd symview-git
+ install -D -m755 symview.py "$pkgdir/usr/bin/symview"
+}
diff --git a/push.sh b/push.sh
new file mode 100755
index 000000000000..06369432d45f
--- /dev/null
+++ b/push.sh
@@ -0,0 +1,5 @@
+#!/usr/bin/env bash
+makepkg --printsrcinfo > .SRCINFO
+git add -A
+git commit -m "Mods"
+git push origin master