summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2017-12-29 15:47:20 -0500
committerDrew DeVault2017-12-29 15:47:53 -0500
commit6f1dbf37dec5acb0b5f0a52d43f3044c1277ff34 (patch)
tree13ac34cfc345a0a1142d7a74572b274bcc1350e8
downloadaur-6f1dbf37dec5acb0b5f0a52d43f3044c1277ff34.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
-rw-r--r--synapse.service12
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..750808f99e96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Dec 29 20:47:34 UTC 2017
+pkgbase = synapse-bt-git
+ pkgdesc = Lightweight bittorrent daemon
+ pkgver = r538.cf0a0b4
+ pkgrel = 1
+ url = https://synapse-bt.org
+ arch = i686
+ arch = x86_64
+ license = ISC
+ makedepends = cargo
+ depends = openssl
+ depends = c-ares
+ provides = synapse-bt
+ conflicts = synapse-bt
+ source = git+https://github.com/Luminarys/synapse
+ source = synapse.service
+ sha256sums = SKIP
+ sha256sums = e21042763f6c56924a3063697d641855a0900285e6c7eacc6253e1c338cb2deb
+
+pkgname = synapse-bt-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4486c4b87848
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+synapse
+synapse-bt-git-r538.cf0a0b4-1-x86_64.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b2f73a15922
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=synapse-bt-git
+provides=('synapse-bt')
+conflicts=('synapse-bt')
+pkgver=r538.cf0a0b4
+pkgrel=1
+pkgdesc='Lightweight bittorrent daemon'
+arch=('i686' 'x86_64')
+url='https://synapse-bt.org'
+license=('ISC')
+depends=('openssl' 'c-ares')
+makedepends=('cargo')
+source=(
+ git+https://github.com/Luminarys/synapse
+ synapse.service
+)
+sha256sums=('SKIP'
+ 'e21042763f6c56924a3063697d641855a0900285e6c7eacc6253e1c338cb2deb')
+
+pkgver() {
+ cd synapse
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd synapse
+ cargo build --release --all
+}
+
+package() {
+ cd synapse
+ mkdir -p "$pkgdir"/usr/lib/systemd/user/ "$pkgdir"/usr/bin
+ install -Dm755 target/release/synapse "$pkgdir"/usr/bin
+ install -Dm755 target/release/sycli "$pkgdir"/usr/bin
+ install -Dm644 "$srcdir"/synapse.service "$pkgdir"/usr/lib/systemd/user/
+}
diff --git a/synapse.service b/synapse.service
new file mode 100644
index 000000000000..be3d5ba89737
--- /dev/null
+++ b/synapse.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=synapse bittorrent daemon
+After=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/env RUST_BACKTRACE=1 /usr/bin/synapse
+WorkingDirectory=%h
+Restart=always
+
+[Install]
+WantedBy=default.target