diff options
author | etckeeper | 2022-05-02 11:32:32 +0200 |
---|---|---|
committer | etckeeper | 2022-05-02 11:32:32 +0200 |
commit | 7104c750e0691352c3714609b9d62a1212a282ee (patch) | |
tree | 1a06e5d64ddd2bdc38c3ef2602c0a4b9afe8e9a9 | |
parent | 3c7b58982c3fb1c53897a8e24208cffa5e39bee3 (diff) | |
download | aur-7104c750e0691352c3714609b9d62a1212a282ee.tar.gz |
version bump
fixed package to conform to pkgbuild guidelines ( thanks xiretza )
added synapse_auto_compressor binary to the package ( thanks xiretza )
-rw-r--r-- | .SRCINFO | 10 | ||||
-rw-r--r-- | PKGBUILD | 27 |
2 files changed, 25 insertions, 12 deletions
@@ -1,7 +1,7 @@ pkgbase = synapse-compress-state pkgdesc = A tool to compress some state in a Synapse instance's database - pkgver = 0.1.0 - pkgrel = 2 + pkgver = 0.1.2 + pkgrel = 1 url = https://github.com/matrix-org/rust-synapse-compress-state arch = x86_64 arch = armv6h @@ -9,8 +9,8 @@ pkgbase = synapse-compress-state arch = aarch64 license = Apache makedepends = rust - source = synapse-compress-state-0.1.0::https://github.com/matrix-org/rust-synapse-compress-state/archive/v0.1.0.tar.gz - sha256sums = ac57d264a99157174cfb6564cb12ef9453229ec5771e57cd990f3eb78efdb1b1 + makedepends = python + source = synapse-compress-state-0.1.2::https://github.com/matrix-org/rust-synapse-compress-state/archive/v0.1.2.tar.gz + sha256sums = e8cd1933545fc4d97e5f68d7da242fba53ab642869937e4fb65f4ba39ddc8fab pkgname = synapse-compress-state - @@ -1,23 +1,36 @@ # Maintainer: BrainDamage +# Contributor: xiretza pkgname=synapse-compress-state -pkgver=0.1.0 -pkgrel=2 +pkgver=0.1.2 +pkgrel=1 pkgdesc="A tool to compress some state in a Synapse instance's database " arch=('x86_64' 'armv6h' 'armv7h' 'aarch64') url="https://github.com/matrix-org/rust-synapse-compress-state" -makedepends=('rust') +makedepends=('rust' 'python') license=('Apache') source=("${pkgname}-${pkgver}::https://github.com/matrix-org/rust-synapse-compress-state/archive/v${pkgver}.tar.gz") -sha256sums=('ac57d264a99157174cfb6564cb12ef9453229ec5771e57cd990f3eb78efdb1b1') +sha256sums=('e8cd1933545fc4d97e5f68d7da242fba53ab642869937e4fb65f4ba39ddc8fab') + +prepare() { + cd "${srcdir}/rust-${pkgname}-${pkgver}" + + cargo fetch --locked --target "${CARCH}-unknown-linux-gnu" +} build() { cd "${srcdir}/rust-${pkgname}-${pkgver}" + cargo build --release --locked + + export RUSTUP_TOOLCHAIN=stable + export CARGO_TARGET_DIR=target + cargo build --workspace --frozen --release --all-features } package() { - cargo install --locked --path "${srcdir}/rust-${pkgname}-${pkgver}" --root "${pkgdir}/usr" - # delete the leftover crates file - rm -f "${pkgdir}/usr/.crates.toml" "${pkgdir}/usr/.crates2.toml" + cd "${srcdir}/rust-${pkgname}-${pkgver}" + + install -Dm0755 -t "${pkgdir}/usr/bin/" 'target/release/synapse_compress_state' + install -Dm0755 -t "${pkgdir}/usr/bin/" 'target/release/synapse_auto_compressor' } |