summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasukaminato2023-02-27 23:15:57 +0900
committerasukaminato2023-02-27 23:15:57 +0900
commit2bcfefb4a70f3ed5c933854731a2805eccb4e219 (patch)
treeeb6d6dd25da4e558794ef59ea75d6bfdc3f56c9a
downloadaur-2bcfefb4a70f3ed5c933854731a2805eccb4e219.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53e948933b47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sync-current-directory-git
+ pkgdesc = Sync current directory between your shell and a file manager
+ pkgver = r52.9b243ff
+ pkgrel = 1
+ url = https://github.com/cshuaimin/scd
+ arch = any
+ license = MIT
+ makedepends = cargo
+ makedepends = git
+ depends = fish
+ provides = scd
+ source = git+https://github.com/cshuaimin/scd.git
+ sha256sums = SKIP
+
+pkgname = sync-current-directory-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..45892b416b7d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.zst
+/scd/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f5dfdddfae5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: asukaminato <asukaminato at nyan dot eu dot org>
+pkgname=sync-current-directory-git
+pkgver=r52.9b243ff
+pkgrel=1
+epoch=
+pkgdesc="Sync current directory between your shell and a file manager"
+arch=("any")
+url="https://github.com/cshuaimin/scd"
+license=('MIT')
+groups=()
+depends=('fish')
+makedepends=('cargo' 'git')
+checkdepends=()
+optdepends=()
+provides=('scd')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/cshuaimin/scd.git")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+pkgver(){
+ cd scd
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+build() {
+ pushd scd
+ cargo build --release
+}
+
+package() {
+ pushd scd
+ install -Dm755 target/release/scd -t $pkgdir/usr/bin/
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}