summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Kröning2021-04-19 17:00:53 +0200
committerMartin Kröning2021-04-19 17:00:53 +0200
commitc939a59b13c4e72716f9ff0eb598bf847d4a6a34 (patch)
tree5cf51ed7f89f25710e17174e9ad9dd7f7cc7d76f
parentfc07f5aee95fe84b8cdd585a3305bf287a3bcfba (diff)
downloadaur-c939a59b13c4e72716f9ff0eb598bf847d4a6a34.tar.gz
Version 2.4.2-2 from rwthmoodle
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4b4c8353d39..c059a5b9ac41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = sync-my-l2p
pkgdesc = Sync the L2P and moodle instance of RWTH Aachen University
pkgver = 2.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://syncmyl2p.de/
arch = x86_64
license = LGPL3
depends = qt5-base
depends = hicolor-icon-theme
- source = Sync-my-L2P-2.4.2.tar.gz::https://github.com/RobertKrajewski/Sync-my-L2P/archive/v2.4.2.tar.gz
- source = https://github.com/RobertKrajewski/Sync-my-L2P/releases/download/v2.4.2/SyncMyL2P-2.4.2-linux.AppImage
- sha256sums = 2e10daef909711f9894190e6c8d8856b43d0dde8ec3348a0e31d11628b1fb262
- sha256sums = d157702966520c279ace87e190ca7a9e06fb89b74839903513f0d02d2ff90bd7
+ source = Sync-my-L2P-2.4.2.tar.gz::https://github.com/rwthmoodle/Sync-my-L2P/archive/v2.4.2.tar.gz
+ source = SyncMyL2P-2.4.2-linux.AppImage::https://github.com/rwthmoodle/Sync-my-L2P/releases/download/v2.4.2/SyncMyL2P-4.2.2-linux.AppImage
+ sha256sums = 58c6847cf96a03025009a6526f54f5967ee754b580a8fcfe3ab2c6d24c18266e
+ sha256sums = 013aa9a08b1badd19c47ea5d826c0b146409e999787ca24df01439e086e8ceab
pkgname = sync-my-l2p
diff --git a/PKGBUILD b/PKGBUILD
index b5b8f42d7fb3..aea9567c1f03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
_realname=Sync-my-L2P
pkgname=sync-my-l2p
pkgver=2.4.2
-pkgrel=1
+pkgrel=2
pkgdesc='Sync the L2P and moodle instance of RWTH Aachen University'
arch=('x86_64')
url='https://syncmyl2p.de/'
license=('LGPL3')
depends=('qt5-base' 'hicolor-icon-theme')
-source=("$_realname-$pkgver.tar.gz::https://github.com/RobertKrajewski/$_realname/archive/v$pkgver.tar.gz"
- "https://github.com/RobertKrajewski/$_realname/releases/download/v$pkgver/SyncMyL2P-$pkgver-linux.AppImage")
-sha256sums=('2e10daef909711f9894190e6c8d8856b43d0dde8ec3348a0e31d11628b1fb262'
- 'd157702966520c279ace87e190ca7a9e06fb89b74839903513f0d02d2ff90bd7')
+source=("$_realname-$pkgver.tar.gz::https://github.com/rwthmoodle/$_realname/archive/v$pkgver.tar.gz"
+ "SyncMyL2P-2.4.2-linux.AppImage::https://github.com/rwthmoodle/$_realname/releases/download/v$pkgver/SyncMyL2P-4.2.2-linux.AppImage")
+sha256sums=('58c6847cf96a03025009a6526f54f5967ee754b580a8fcfe3ab2c6d24c18266e'
+ '013aa9a08b1badd19c47ea5d826c0b146409e999787ca24df01439e086e8ceab')
prepare() {
# Setup client_id
@@ -22,6 +22,9 @@ prepare() {
cd "$_realname-$pkgver"
sed --in-place "s/\(#define CLIENTID\) .*/\1 \"$client_id\"/g; /#error ERROR: NO CLIENTID IN CLIENTID.H DEFINED/d" include/clientId.h
+ # Fill in version number
+ sed "s/PRODUCT_VERSION/$pkgver/g" gui/info.ui.template > gui/info.ui
+
mkdir -p build
}